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Chapter 1: Working in 3-D 
Working in 3-D on a computer requires that you visualize three-dimensional objects drawn on a two 
dimensional medium—the computer screen. Rhino provides tools to help you do this. 

You can manipulate the views and look at your model from different angles easily by dragging with 
your right mouse button. You can do this in both a wireframe view and a shaded view. 

Why NURBS modeling 
NURBS (non-uniform rational B-splines) are mathematical representations that can accurately model 
any shape from a simple 2-D line, circle, arc, or box to the most complex 3-D free-form organic 
surface or solid. Because of their flexibility and accuracy, NURBS models can be used in any process 
from illustration and animation to manufacturing. 

NURBS geometry is an industry standard for designers who work in 3-D where forms are free and 
flowing; where both form and function is important. Rhino is used in marine, aerospace, and 
automobile interior and exterior design. Makers of household and office appliances, furniture, medical 
and sports equipment, footwear, and jewelry use Rhino to create free-form shapes. 

NURBS modeling is also widely used by professional animators and graphic artists. The advantage 
over using polygon modelers is that there are no facets. The models can be rendered at any 
resolution. A mesh can be created from the model at any resolution. For more information about the 
mathematics of NURBS, see the Rhino Help topic. 

The Rhino interface 
In the exercises, you will use Rhino’s commands, navigation tools, shaded modes, render, and use 
some basic object manipulation. 

Open the tutorial model 

Review the Rhino Help topic The Rhino Window. 
From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Select the file Start.3dm and click the Open button. 
This model contains four objects: a box, a cone, a cylinder, and a sphere. 

Menus, buttons, and command prompt 
With Rhino, you can work with the menus, the toolbar buttons, or by typing commands at the 
command prompt. This gives you the flexibility to work in a way that is comfortable for you. 

Rhino’s toolbars also provide a way to create your own custom environment. Drag toolbars to float 
them anywhere on the screen, change their shape, or dock them at the edge of the Rhino screen. 

Note: Hold the Ctrl key while moving a toolbar to prevent docking. 

Many toolbar buttons have a second command that you can access by right-clicking the button. 

To display a button tooltip 

Hover your mouse over the button. 
The command names that are activated with the left and right mouse clicks display. 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/User_Interface/Rhino_window.htm
http://www.rhino3d.com/5/help/commands/open.htm
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Change the view 
Before starting the next command, use Rhino's mouse navigation to change the view. 

Set up the view 

Click in the Top viewport, zoom out a little (scroll the mouse wheel). 
Pan (click the right mouse button and drag) to give yourself some room). 

Start a command from the menu 
Most Rhino commands are arranged in the menus. 

Start the Cone command 

Review the Rhino Help topic for the Cone command. 
From the Solid menu, click Cone. 

Draw the cone 

At the Base of cone… prompt, in the Top viewport, click with the mouse to pick the center 
point for the base of the cone. 
At the Radius… prompt, in the Top viewport, drag the mouse and click to draw the cone’s base. 
At the End of cone prompt, in the Front viewport, drag the mouse and click to draw the cone’s 
point. 

Start a command from a toolbar button 
Toolbars provide a graphical interface to the commands. 

Start the Box command 

Review the Rhino Help topic for the Box command. 
From the Main1 toolbar, click Box, and then click Corner to Corner, Height. 
Note: The Main1 toolbar is normally docked on the left side of the Rhino window. 

Draw the box 

At the First corner of base… prompt, in the Perspective viewport, click the mouse to pick a 
corner point for the box. 
At the Other corner of base... prompt, click the mouse to pick the opposite corner for the box. 
At the Height... prompt, in the Front viewport, click the mouse to pick the height for the box. 

Admire your work 

Click in the Perspective view. 
On the View menu, click Shaded. 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/commands/cone.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/commands/box.htm
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Drag with the right mouse button to rotate the Perspective view. 

Start from the command line 
You can start a command by typing the name at the command prompt. 

Start the Sphere command by typing 

Review the Rhino Help topic for the Sphere command. 
At the command prompt, type Sphere. 
When you type the first letters of a command, a list of possible commands appears. 

Select the Sphere command from the list. 

Draw the sphere 

At the Center of sphere… prompt, in the Perspective viewport, click the mouse to pick the 
center point for the sphere. 
At the Radius… prompt, in the Perspective viewport, move the mouse to draw the sphere and 
click. 

Start modeling 
Rhino is a "command driven" program. Actions are activated by commands. Commands are accessed 
by typing at the command prompt, through the menus, or the toolbars. 

You have already used the menus to start commands. Before we go further, explore using the typed 
command names and the toolbar buttons. You may find one method easier than another. The choice 
is yours and there is no preference for one method over another. 

To start your first Rhino model 

Start Rhino. 
From the File menu, click New. 
In the Open Template File dialog box, select SmallObjects - centimeters.3dm and click 
Open. 

In this session you will 

Start a command by typing at the command line. 
Start a command by choosing from the menu. 
Start a command by choosing from a toolbar button. 

Undo a mistake 
If you did something you did not want to do, you can undo your actions. 

Undo a command 

From the Edit menu, click Undo. 
The prompt displays the action you are undoing. 

You can undo a series of commands. 

You can also Redo the Undo if you go too far. 

Redo commands 

From the Edit menu, click Redo. 
Note: To cancel a command any time, press the Esc key. 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/commands/sphere.htm
http://www.rhino3d.com/5/help/commands/new.htm
http://www.rhino3d.com/5/help/commands/undo.htm
http://www.rhino3d.com/5/help/Commands/Undo.htm#Redo
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Command history window 
The command history window contains the command line and the command history. The window is 
normally docked at the top of the Rhino window, but you can dock it at the bottom of the screen or 
float it just like any toolbar. 

The command prompt appears on the command line and is where you can type command names, set 
options, enter distances and angles for drawing, and read the prompts for the commands. 

The command prompt displays options for the command in parentheses. To activate an option, click 
the option with the mouse or type the option name or accelerator letter (the underlined letter in the 
option). 

Options give you alternate methods for using the command. Prompts are messages to you to select 
objects to act on, to enter information, or to enter a point on the screen. As you start to build objects, 
prompts become increasingly important, since they give you valuable feedback about what to do 
next. 

Because of the autocomplete feature and command list display, many people find that once they learn 
the program, they can type the command names faster than they can find them on the menus or 
toolbars. 

Command-line options 
Command options change how a command acts. For example, when you draw a circle, the circle is 
normally drawn on the active construction plane. The Circle command has several options including 
Vertical and AroundCurve. Command options appear in parentheses at the prompt. 

To use a command option, click the option name or type the underlined letter of the option or the 
whole option name. 

Choose a command option 

At the command prompt, type Circle. 
Or, type Ci. 

As soon as you have typed enough letters to uniquely identify the command, the Circle 
command automatically completes at the prompt. Press Enter or click the command name. 

At the command prompt, the prompt for the Circle command appears: 
Center of circle (Deformable Vertical 2Point 3Point Tangent AroundCurve FitPoints) 

To draw a circle vertical to the active construction plane, use the Vertical option. 
Click Vertical or, type V. 

Select objects 
Most operations you will do in Rhino require that you select one or more objects. One method of 
selecting is to click anywhere on the object. Click away from the object to deselect it. This method 
allows you to select one object at a time. 

To select additional objects, hold the Shift key while clicking the objects. 
To remove objects from the collection of selected objects, hold the Ctrl key and click the objects 
again. 
To cancel the selection, click away from the objects or press the Esc key. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Select Objects.3dm and then click the Open button. 

http://www.rhino3d.com/5/help/Commands/circle.htm
http://www.rhino3d.com/5/help/Popup_Actions/shift_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/esc_key.htm
http://www.rhino3d.com/5/help/commands/open.htm
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Practice selecting objects 

In the Perspective viewport, click to select the sphere. 

 

Hold the Shift key and select the cylinder. 
The cylinder is added to the selection. 

 
Hold the Ctrl key and select the sphere again. 
The sphere is removed from the selection. 

 
Click away from the objects, or press the Esc key. 
The selection is canceled. 

 

http://www.rhino3d.com/5/help/Popup_Actions/shift_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/esc_key.htm
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Select objects with windows 
Another method is to make a window selection or a crossing selection to select multiple objects in one 
operation. 

You can click in an open area of the screen and drag to create a selection window. To make a window 
selection click in an open area of the screen and drag to the right. To make a crossing selection click 
in an open area of the screen and drag to the left. 

A window selection, selects all objects completely enclosed by the window. A crossing selection, 
selects all objects that are enclosed by the window or any object the window crosses. 

To add objects, hold the Shift key while making a window or crossing selection. To remove objects, 
hold the Ctrl key while making a window or crossing selection. 

Practice window and crossing select 

In the Perspective viewport, click and drag a window around the sphere. 

 

In the Perspective viewport, hold the Shift key then click and drag a window around the box 
and the cylinder. 
The cylinder and box are added to the selection. 

 

In the Perspective viewport, hold the Ctrl key then click and drag a crossing over the box and 
cylinder. 
The cylinder and box are removed from the selection. 

 

http://www.rhino3d.com/5/help/Popup_Actions/shift_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
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Repeat the last command 
Many tasks in Rhino are repetitive. You might want to move or copy several objects, for example. 
Several methods are provided for repeating commands. 

To repeat the last command 

Press the Enter key when no command is active. 
In addition to pressing the Enter key on your keyboard, you can press the spacebar or click the 
right mouse button in a viewport. These all perform the same function. 
Some commands, such as Undo and Delete do not repeat. Instead, the command prior to these 
commands is repeated. This prevents you from accidentally undoing too many commands or 
deleting objects accidentally. In addition, you often want to repeat the command you were using 
before undoing a mistake. You can define the list of commands that do not repeat to suit your 
own way of working. 

Get help any time 
To get answers to your questions about the mathematical principles involved in 3-D modeling, see: 
http://www.mathopenref.com/. 

The Rhino Help file is the major resource for detailed information on specific commands. 

To get help on a specific command 

To get Help for a command, press F1 while the command is running. 
On the Rhino Help menu, click Command Help. 
The Rhino Help will display in a dockable window. 

Click Auto-Update to display the Help topic for the current command. 
The Help window appears with the specific command topic visible. 

Find the answers to frequently asked questions at: http://www.rhino3d.com/support.htm. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.mathopenref.com/
http://www.rhino3d.com/support.htm
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Chapter 2: Rhino Objects 
The fundamental geometric objects in Rhino are points and NURBS curves, surfaces, polysurfaces and 
polygon mesh objects.  

Points 
Point objects mark a single point in 3-D space. They are the simplest objects in Rhino. Points can be 
placed anywhere in space. Points are most often used as placeholders. 

 

Curves 
A Rhino curve is similar to a piece of wire. It can be straight or wiggled, and can be open or closed. 

A polycurve is several curve segments joined together end to end. 

Rhino provides many tools for drawing curves. You can draw straight lines, polylines that consist of 
connected line segments, arcs, circles, polygons, ellipses, helixes, and spirals. 

You can also draw curves using curve control points and draw curves that pass through selected 
points. 

 

Curves in Rhino include lines, arcs, circles, free-form curves, and combinations of these. Curves can 
be open or closed, planar or non-planar. 

Surfaces 
A surface is like a rectangular stretchy rubber sheet. The NURBS form can represent simple shapes, 
such as planes and cylinders, as well as free-form, sculptured surfaces. 

All surface creation commands in Rhino result in the same object: a NURBS surface. Rhino has many 
tools for constructing surfaces directly or from existing curves. 

http://www.rhino3d.com/5/help/Commands/Point.htm
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All NURBS surfaces have an inherently rectangular organization. Even a closed surface such as a 
cylinder is like a rectangular piece of paper that has been rolled up so two opposite edges are 
touching. The place where the edges come together is called the seam. If a surface does not have a 
rectangular shape, either it has been trimmed or the control points on the edges have been moved. 

 

Closed and open surfaces 
A surface can be open or closed. An open cylinder is closed in one direction. 

A torus (donut shape) is closed in two directions. 

 

Surface control points 
The shape of a surface is defined by a set of control points that are arranged in a rectangular pattern. 
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Trimmed and untrimmed surfaces 
Surfaces can be trimmed or untrimmed. A trimmed surface has two parts: a surface that underlies 
everything and defines the geometric shape, and trimming curves that mark sections of the 
underlying surface that are removed from view. 

Trimmed surfaces are created with commands that trim or split surfaces with curves and other 
surfaces. Some commands create trimmed surfaces directly. 

 

Since it can be important for you to know if a surface is trimmed, the Properties command lists the 
trimmed or untrimmed state of the surface. Some Rhino commands work only with untrimmed 
surfaces and some software does not import trimmed NURBS surfaces. 

Trimming curves lie on the underlying surface. This surface may be larger than the trim curves, but 
you will not see the underlying surface because Rhino does not draw the part of the surface that is 
outside the trim curves. Every trimmed surface retains information about its underlying surface 
geometry. You can remove the trimming curve boundaries to make the surface untrimmed with the 
Untrim command. 

 

If you have a trim curve that runs across a surface, the trim curve itself does not have any real 
relationship to the control point structure of the surface. You can see this if you select such a trimmed 
surface and turn its control points on. You will see the control points for the whole underlying surface. 

http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm#Untrim
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If you create a surface from a planar curve, it can be a trimmed surface. The illustrated surface was 
created from a circle. The control points display shows the rectangular structure of the surface. 

 

The Untrim command removes the trimming curve from the surface to get back to the underlying 
untrimmed rectangular surface. 

 

Surface isoparametric and edge curves 
In wireframe view, surfaces look like a set of crossing curves. These curves are called isoparametric 
curves or isocurve. These curves help you visualize the shape of the surface. Isoparametric curves do 
not define the surface the way the polygons do in a polygon mesh. They are merely a visual aid that 
allows you to see the surface on the screen. When a surface is selected, all of its isoparametric curves 
highlight. 

Edge curves bound the surface. Surface edge curves can be used as input to other commands. 

http://www.rhino3d.com/5/help/Commands/Trim.htm#Untrim
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Isocurves (1), Edge curves (2). 

Polysurfaces 
A polysurface consists of two or more surfaces that are joined together. A polysurface that encloses a 
volume of space defines a solid. 

 

Solids 
A solid is a surface or polysurface that encloses a volume. Solids are created anytime a surface or 
polysurface is completely closed. Rhino creates single-surface solids, polysurface solids, and extrusion 
solids.  

A single surface can wrap around and join itself. Example commands include Sphere, Torus, and 
Ellipsoid. Control points can be displayed on single-surface solids and moved to change the surface. 

 

Some Rhino commands create polysurface solids. Pyramid, Cone, and TCone are examples of 
commands that create polysurface solids. 

The SolidPtOn command turns on grip points for polysurfaces, which act like control points. 

http://www.rhino3d.com/5/help/Commands/Sphere.htm
http://www.rhino3d.com/5/help/Commands/Torus.htm
http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Commands/Pyramid.htm
http://www.rhino3d.com/5/help/Commands/cone.htm
http://www.rhino3d.com/5/help/Commands/TCone.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm#SolidPtOn
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Extrusions 
Light-weight extrusions are object created using only a length and a profile curve. The Box, 
Cylinder, Tube, and ExtrudeCrv commands create extrusion objects. Extrusions can be closed with 
a planar cap or open. These objects can be converted to polysurfaces if necessary to add additional 
information for editing. 

 

Meshes 
Because there are many modelers that use polygon meshes to represent geometry for rendering and 
animation, stereolithography, visualization, and finite element analysis, the Mesh command 
translates NURBS geometry into polygonal meshes for export. In addition, the Mesh creation 
commands MeshSphere, MeshBox, MeshCylinder, etc., draw mesh objects. 

 

Note: There is no easy way to convert a mesh model into a NURBS model. The information that 
defines the objects is completely different. However, Rhino has a few commands for drawing curves 
on meshes and extracting vertex points and other information from mesh objects to assist in using 
mesh information to create NURBS models. 

http://www.rhino3d.com/5/help/Commands/Box.htm
http://www.rhino3d.com/5/help/Commands/cylinder.htm
http://www.rhino3d.com/5/help/Commands/Tube.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/Mesh.htm
http://www.rhino3d.com/5/help/Commands/MeshSphere.htm
http://www.rhino3d.com/5/help/Commands/MeshBox.htm
http://www.rhino3d.com/5/help/Commands/MeshCylinder.htm
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Chapter 3: Viewports 
The viewport title has some special functions for manipulating the viewport. 

Click the title to make the viewport active without disturbing the view. 
Drag the viewport title to move the viewport. 
Double-click the viewport title to maximize the viewport. Double-click again to restore the size to 
normal. 

Viewport projection 
Viewports can have one of three projections: parallel, perspective or two-point perspective. 

Right mouse navigation works differently in the two viewport styles. In parallel views, right-mouse 
dragging pans the view. In perspective views, right-mouse dragging rotates the view. In the usual 
four-viewport layout, there are three parallel viewports and one perspective viewport. 

Parallel 
Parallel views are also called orthogonal views in some systems. In a parallel view, all the grid 
lines are parallel to each other, and identical objects look the same size, regardless of where they 
are in space. 

 

Perspective 
In a perspective view, grid lines converge to a vanishing point. This provides the illusion of depth 
in the viewport. Perspective projection makes objects farther away look smaller. 

 

Viewport navigation 
Rhino’s easy navigation helps you to visualize your model. 

The simplest way to change the view is to drag the mouse with right mouse button held down. This 
pans the view in parallel views and rotates the view in perspective views. 

You can change your view in the middle of a command to see precisely where you want to select an 
object or choose a point. 

To zoom in and out, hold down the Ctrl key and drag up and down with the right mouse button held 
down. If you have a mouse with a wheel, use the wheel to zoom in and out. 

 
Pan 

In parallel viewports (for example: Top, Front, and Right), drag with the right mouse 
button. 

In perspective viewports, Shift + drag with the right mouse button. 
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RotateView 

In parallel viewports (for example: Top, Front, and Right), Ctrl + Shift + drag with 
the right mouse button. 

In perspective viewports, drag with the right mouse button. 

 
Zoom 

Ctrl+ drag the right mouse button up and down 

Rotate the mouse wheel. 

Mouse navigation 
Working in 3-D on a computer requires visualizing three-dimensional objects drawn on a two-
dimensional medium—the computer screen. Rhino provides tools to help do this. 

Drag with the right mouse button to easily manipulate the views to look at the model from various 
angles. Use the right mouse button view manipulations in both wireframe and shaded views. 

To pan in a viewport 

In the Top viewport, drag the mouse with the right mouse button held down to pan the view. 

To zoom in and out with the right mouse button 

In the Top viewport, hold the Ctrl key, click and hold the right mouse button, and drag the 
mouse up and down. 
Drag up to zoom in. 
Drag down to zoom out. 

Restore a view 

If you get lost, there are several ways to get yourself reoriented: 

Press the Home key to step back through your view changes. 
Press the End key to step forward through your view changes. 
To set your view so you are looking straight down on the construction plane, use the Plan 
command. 
To bring all your objects into view, use the Zoom command Extents option. 

Practice rotating the view 

Click the left mouse button in the Perspective viewport to make it active. 
An active viewport is the viewport where all your commands and actions take place. The active 
viewports title highlights so you can easily see which viewport is active. 

In the Perspective view, drag the mouse with the right mouse button held down to rotate the 
view and see the objects from a different angle. 

Viewport title menu 
Right-click or click the down arrow on any viewport title to display a menu. From this menu, pan, 
rotate, zoom, set one of the standard views, set a construction plane, set the camera and target 
locations, choose a shading option, set the grid, and set other viewport properties. 

Viewport display modes 
You can view your model in a variety of ways that depend on your own needs. Wireframe display 
usually offers the fastest display speed, shaded modes offer the ability to view surfaces and solids 
with shading to help you visualize the shapes. 

http://www.rhino3d.com/5/help/User_Interface/Rhino_window.htm
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Standard and customized shaded modes allow easier visualization of surfaces and solids. 

Wireframe display 
In wireframe view, surfaces look like a set of crossing curves. These curves are called isoparametric 
curves or isocurves. 

Isocurves do not define the surface the way the polygons do in a polygon mesh. They are merely a 
visual aid. 

The Wireframe mode sets the viewport display to wireframe. 

 

Wireframe mode 

Click a mouse button in the Perspective viewport to make it active. 
An active viewport is the viewport where all your commands and actions take place. 

On the viewport title menu, click Wireframe. 

 

Shaded display 
Shaded modes display surfaces and solids with the surfaces shaded using their layer, object, or 
custom color. You can work in any of the shaded modes. The surfaces are opaque or transparent. 

The Shaded mode sets the viewport display to shaded mode. 

 

http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
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Shaded mode 

On the viewport title menu, click Shaded. 

 

Rotate your view by holding down the right mouse button and dragging from the bottom of the 
view toward the top. 
You are now under the objects looking up. 

The construction plane grid helps you stay oriented. If the objects are behind the grid, you are 
looking at the bottom of the construction plane. 

Press the Home key to undo your view changes. 

Rendered display 

Rendered viewport display shows the objects with lighting and render materials applied 

The Rendered mode sets the viewport display to rendered mode. 

 

Other shaded modes 
Other display modes and custom settings are described in the Rhino Help. 

 
Artistic (left) and Pen (right) display modes. 

http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
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Viewport title 
The viewport title has some special functions for viewport control. 

Click the title to make the viewport active without disturbing the view. 
Drag the viewport title to move the viewport. 
Double-click the viewport title to maximize the viewport. Double-click again to restore the size to 
normal. 

Viewport title menu 
Right-click the viewport title or click the down-arrow on the menu to display the viewport title 
menu. 
From the viewport title menu you can maximize the viewport, pan, rotate, zoom, set one of the 
standard views, set a construction plane, set the camera and target locations, choose a shading 
option, set the grid, and open the Viewport Properties dialog box. 

http://www.rhino3d.com/5/help/Commands/ViewportProperties.htm
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Chapter 4: Modeling Aids 
The cursor can always move freely in space, but chances are, you will want to relate your modeling 
elements to the construction plane grid or to existing objects. You can restrict the cursor’s movement 
to the grid, enter specific distances and angles from a point, and snap to specific locations on existing 
objects. 

The Rhino cursor 
There are two parts of the cursor: the cursor (1) and the marker (2). The cursor always follow the 
mouse movement. 

The marker sometimes leaves the center of the cursor because of some constraint on it such as grid 
snap or ortho. The marker is a dynamic preview of the point that will be picked when the left mouse 
button is clicked. 

When the marker is constrained, in elevator mode, for example, a tracking line (3) also displays. 

Constraints move your marker to a specific point in space or make its movement track according to 
the constraint so you can model accurately. 

 

Grid snap 
Grid snap constrains the marker to an imaginary grid that extends infinitely. You can set the snap 
spacing to any value. 

Click the Grid Snap button on the status bar to turn grid snap on and off. 

Ortho mode 
Ortho mode constrains the marker movement or object dragging to a specific set of angles. By 
default, this is parallel to the grid lines, but you can change this. Ortho is similar to the axis lock 
function found in drawing or animation programs. 

Click the Ortho pane on the status bar to turn ortho on and off. Press and hold the Shift key to 
temporarily toggle the ortho mode. 

Another common use for ortho is to constrain object dragging to a specific axis. 

Ortho is active after the first point for a command. For example, after picking the first point for a line, 
the second point is constrained to the ortho angle. 

 
Ortho off. 

http://www.rhino3d.com/5/help/Popup_MoreInformation/Cursor_tracking_line.htm
http://www.rhino3d.com/5/help/User_Interface/Rhino_window.htm
http://www.rhino3d.com/5/help/User_Interface/Rhino_window.htm
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Ortho on. 

If you only need a different angle for a single operation, angle constraint is faster to use. Enter a 
specific angle for one operation instead of changing the ortho angle and then changing it back. 

Object snaps 
Object snaps constrain the marker to specific points on an object. When Rhino asks you to specify a 
point, you can constrain the marker to specific parts of existing geometry. When an object snap is 
active, moving the cursor near a specified point on an object causes the marker to jump to that point. 

In this chapter you will learn: 

How to use object snaps to find specific points on geometry. 
How to set, clear, and suspend persistent object snaps. 
How to use one-time object snaps. 
How to use object snaps in combination with other modeling aids. 

Object snaps can persist from pick to pick, or can be activated for one pick only. Multiple persistent 
object snaps can be set from the status bar. All object snaps behave similarly, but snap to different 
parts of existing geometry. In addition, there are special object snaps that work for one pick only. 

Persistent object snaps 
Use persistent objects snaps to maintain an object snap through choosing several points. Since 
persistent object snaps are easy to turn on and off, you can set them and leave them on until they 
get in your way. You can then set a different one or just disable them. 

Sometimes object snaps interfere with each other and with grid snap or ortho. Object snaps normally 
take precedence over grid snap or other constraints. 

There are other situations where object snaps work in conjunction with other constraints. You will see 
examples of this in this chapter. For more information including video demonstrations, see the Help 
topic “Object Snaps.” 

To turn persistent object snaps on and off 

On the status bar, click the Osnap pane. 
In the Osnap toolbar, check or clear the desired object snaps. 

To suspend all persistent object snaps 

In the Osnap toolbar, click the Disable button. 
All persistent object snaps will be suspended, but remain checked. 

To clear all persistent object snaps 

In the Osnap toolbar, click the Disable button with the right mouse button. 
All persistent object snaps will be cleared. 

To turn on one object snap and turn all others off with one click 

In the Osnap toolbar, right-click the object snap you want to turn on. 

http://www.rhino3d.com/5/help/User_Interface/Rhino_window.htm
http://www.rhino3d.com/5/help/User_Interface/Object_Snaps.htm
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SmartTrack 
SmartTrack™ is a system of temporary reference lines and points that is drawn in the Rhino 
viewport using implicit relationships among various 3-D points, other geometry in space, and the 
coordinate axes' directions. 

Temporary infinite lines (tracking lines) and points (smart points) are available to object snaps very 
much like real lines and points. 

You can snap to intersections of the tracking lines, perpendiculars, and directly to smart points as well 
as intersections of tracking lines and real curves. The tracking lines and smart points are displayed for 
the duration of a command. 

 

Cursor constraints 
When entering points, you can constrain the marker to a distance or angle from the previous point. 
Once you have set the distance, drag the line around to any angle. You can also use further snaps to 
point the line in a specific direction. 

Distance constraint 
During any command that requires two points, such as the Line command, place the first point. Then 
at the next prompt, type a distance and press Enter or the Spacebar. 

The marker will be constrained to the specified distance from the previous point. Drag the cursor 
around the first point and then pick a point. 

 

Angle constraint 
Angle constraint is similar to ortho, but you can set any angle and it is a one-time setting. 

The < symbol is used because it is similar to the symbol used in geometry to indicate an angle. 

The marker will be constrained to lines radiating from the previous point separated by the specified 
angle, where the first line is the specified number of degrees counterclockwise from the x-axis. If you 
enter a negative number, the angle will be clockwise from the x-axis. 

Distance and angle together 
Distance and angle constraints can be used at the same time. Type the distance at the prompt and 
press Enter, and then type < and then the angle and press Enter. The order of the distance and 
angle does not matter. The marker will drag around your original point at angle increments at the 
specified distance. 

http://www.rhino3d.com/5/help/options/modeling_aids/smarttrack.htm
http://www.rhino3d.com/5/help/Commands/Line.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/User_Interface/cursor_constraints.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Elevator mode 
Pick a second point to specify the z-coordinate of the desired point. It is easiest to see this in a 
different viewport or use the Perspective viewport. Drag the mouse cursor around to see the marker 
move vertically from the base point along the tracking line. 

Pick the point with the mouse or type the height above the construction plane. Positive numbers are 
above the construction plane; negative numbers are below it. You can use further constraints like 
coordinates, object snaps or grid snap for the first point, and you can use object snaps for the height. 

 
To move the marker in the construction plane z-direction, hold the Ctrl key and click a point on the 
construction plane, and then drag vertically from the construction plane and click to pick a point. This 
constraint is called elevator mode. Using elevator mode to move your pick point vertically from the 
construction plane lets you work more in the Perspective viewport. 

 

http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
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Chapter 5: Coordinate Systems 
Rhino uses two coordinate systems: construction plane coordinates and world coordinates. World 
coordinates are fixed in space. Construction plane coordinates are defined for each viewport. 

Cartesian coordinates 
When Rhino prompts you for a point, if you type x and y Cartesian coordinates, the point will lie on 
the construction plane of the current viewport. For more information about coordinate systems and 
numeric constraints, see the Rhino Help topic, Unit Systems. 

Right-hand rule 
Rhino follows what is called the right-hand rule. The right-hand rule can help you determine the 
direction of the z-axis. Form a right angle with the thumb and forefinger of your right hand. When 
your thumb points in the positive x-direction, your forefinger points in the positive y-direction, and 
the palm of your hand faces in the positive z-direction. 

 

World coordinates 
Rhino contains one world coordinate system. The world coordinate system cannot be changed. When 
Rhino prompts you for a point, you can type coordinates in the world coordinate system. 

The arrow icon in the lower left corner of each viewport displays the direction of the world x-, y-, and 
z-axes. The arrows move to show the orientation of the world axes when you rotate a view. 

 

Construction plane coordinates 
Each viewport has a construction plane. A construction plane is like a tabletop that the cursor 
moves on unless you use coordinate input, elevator mode, or object snaps or a few other instances 
where input is constrained. The construction plane has an origin, x- and y-axes, and a grid. The 
construction plane can be set to any orientation. By default, each viewport’s construction plane is 
independent of those in other viewports. 

The construction plane represents the local coordinate system for the viewport and can be different 
from the world coordinate system. 

 

http://www.rhino3d.com/5/help/Commands/CPlane.htm
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Rhino’s standard viewports come with construction planes that correspond to the viewport. The 
default Perspective viewport, however, uses the world Top construction plane, which is the same 
construction plane that is used in the Top viewport. 

The grid lies on the construction plane. The dark red line represents the construction plane x-axis. 
The dark green line represents the construction plane y-axis. The red and green lines meet at the 
construction plane origin. 

To change the direction and origin of a construction plane, use the CPlane command. Preset 
construction planes (World Top, Right, and Front) give you quick access to common construction 
planes. In addition, you can save and restore named construction planes and import named 
construction planes from another Rhino file. 

2-D construction plane coordinates 

At a prompt, type the coordinate in the format x,y where x is the x-coordinate and y is the y-
coordinate of the point. 

 
A line from 1,1 to 4,2. 

3-D construction plane coordinates 

At a prompt, type the coordinate in the format x,y,z where x is the x-coordinate, y is the y-
coordinate, and z is the z-coordinate of the point. 
There are no spaces between the coordinate values. 

To place a point 3 units in the x-direction, 4 units in the y-direction, and 10 units in the z-
direction from the construction plane origin, type 3,4,10 at the prompt. 
Note If you enter only x- and y-coordinates, the point will lie on the construction plane. 

Relative coordinates 
Rhino remembers the last point used, so you can enter the next point relative to it. Relative 
coordinates are useful for entering a list of points where the relative locations instead of absolute 
locations of the points are known. Use relative coordinates to locate points according to their 
relationship to the previous active point. 

Relative coordinates 

At a prompt, type the coordinates in the format rx,y where r signifies that the coordinate is 
relative to the previous point. 

For example 

Start the Line command. 
At the Start of line… prompt, click to place the first end of the line. 
At the End of line… prompt, type r2,3, and press Enter or the spacebar. 
The line is drawn to a point 2 units in the x-direction and 3 units in the y-direction from the last 
point. 

http://www.rhino3d.com/5/help/Commands/CPlane.htm
http://www.rhino3d.com/5/help/Commands/Line.htm
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Chapter 6: Create Surfaces from Curves 
A common way of working in 3-D is to draw curves that represent edges, profiles, cross-sections, or 
other surface features and then to use surfacing commands to create surfaces from those curves. 

Surface from edge curves 
You can create a surface from three or four curves that form the sides of the surface. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click EdgeSrf.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the EdgeSrf command. 

Create a surface from edge curves 

From the Surface menu, click Edge Curves. 
Select the curves. 

 

Objects change to yellow when you select them. 

A surface is created from the curves that form its edges. 

 

Extrude a curve 

Open the tutorial model 

From the Rhino File menu, click Open. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/EdgeSrf.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
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Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Extrude.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the ExtrudeCrv command. 

Create an extruded surface 

From the Surface menu, click Extrude Curve, and then click Straight. 
Select the curve. 

 

At the Extrusion distance prompt, drag a distance with your mouse and click. 

 

 

Loft through curves 
Lofting creates a smooth surface that blends between selected shape curves. This surface looks 
similar to the Sweep a curve with two rails example, but is created without rail curves. Instead, the 
edges of the surface are created by fitting smooth curves through the shape curves. 

Open the tutorial model 

From the Rhino File menu, click Open. 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
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Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Loft.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the Loft command. 

Create a lofted surface 

From the Surface menu, click Loft. 
Select the three curves and press Enter. 

 

In the Loft Options dialog box, click OK. 

 

Try some of the Style options and then click Preview to see the various loft styles. 

Revolve a curve 
Revolving a curve creates a surface by revolving a profile curve about an axis. This is sometimes 
called lathing. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Revolve.3dm and then click the Open button. 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Loft.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
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Set up modeling aids 

Turn on End object snap to help you locate the endpoints of the axis line. 
In the status bar, click Osnap. 
In the Osnap dialog box, click End. 

Review the Help topic 

Review the Help topic for the Revolve command. 

Create a revolved surface 

From the Surface menu, click Revolve. 
Select the profile curve and press Enter. 

 

At the Start of revolve axis prompt, snap to one end of the axis line. 

 

At the End of revolve axis prompt, snap to the other end of the axis line. 

 

At the Start angle... prompt, select the FullCircle option. 

http://www.rhino3d.com/5/help/User_Interface/Object_Snaps.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Revolve.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Revolve a curve with a rail 
Rail revolve creates a surface by revolving a profile curve around an axis while at the same time 
following a rail curve. This is basically the same as Sweep Along 2 Rails, except one of the rails is a 
central point. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click RailRevolve.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the RailRevolve command. 

Create a revolved surface with a rail curve 

From the Surface menu, click Rail Revolve. 
Select the profile curve (highlighted in yellow below). 

 

At the Select rail curve... prompt, select the rail curve the revolve will follow as shown 
highlighted in yellow in the illustration. 

 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/RailRevolve.htm
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At the Start of RailRevolve axis prompt, snap to an endpoint of the axis line. 

 

At the End of RailRevolve axis prompt, snap to the other end of the axis line. 

 

 

Sweep along a single rail curve 
Sweeping creates a surface with cross sections that maintain the initial orientation of the shape 
curve(s) to the path curve. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Sweep1.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the Sweep1 command. 

Create a sweep surface 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Sweep1.htm
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From the Surface menu, click Sweep 1 Rail. 
Select the rail curve as shown in the illustration. 

 

At the Select cross section curves ... prompt, select the cross-section curve, and press Enter. 

 

In the Sweep 1 Rail Options dialog box, click OK. 

 

Sweep with two rail curves 
Using two rails for a sweep creates a smooth surface through two or more shape curves that follow 
two curve rails. The rails also affect the overall shape of the surface. Use this command when you 
want to control the location of the edges of the surface. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Sweep2.3dm and then click the Open button. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
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Review the Help topic 

Review the Help topic for the Sweep2 command. 

Create a sweep surface with two rail curves 

From the Surface menu, click Sweep 2 Rail. 
Select the first rail curve. 
At the Select second rail... prompt, select the second rail curve. 

 

At the Select cross section curves prompt, select the two cross-section curves (highlighted in 
yellow below), and press Enter. 

 

In the Sweep 2 Rails Options dialog box, click OK. 

 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Sweep2.htm
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Chapter 7: Edit Curves and Surfaces 
The editing operations in this section break objects apart, cut holes in them, and put them back 
together. Some of these commands connect curves to curves or surfaces to surfaces or polysurfaces 
and break a composite curve or polysurface into its components. 

The commands: Join, Explode, Trim, and Split apply to curves, surfaces, and polysurfaces. 

The Rebuild, ChangeDegree, and Smooth commands alter the shape of a curve or surface by 
changing its underlying control point structure. 

In addition, objects have properties that are assigned to them such as color, layer, rendering 
material, and other attributes depending on the object. The Properties command manages these 
properties. 

Join 
The Join command connects curves or surfaces together into one object. For example, a polycurve 
can consist of straight-line segments, arcs, polylines, and free-form curves. The Join command also 
connects adjacent surfaces into a polysurface. 

Explode 
The Explode command removes the connection between joined curves or surfaces. For polysurfaces, 
this is useful if you want to edit each individual surface with control points. 

Trim and Split 
The Trim and Split commands are similar. The difference is when you trim an object, you select the 
parts to remove and they are deleted. When you split an object, all parts are left. 

The Split command will split a surface with a curve, surface, polysurface, or its own isoparametric 
curves. 

The Untrim command removes a surface’s trimming curve, with an option to keep the curve so you 
can re-use it. 

Control-point editing 
You can make subtle changes in the shape of a curve or surface by moving the location of its control 
points. Rhino offers many tools for editing control points. Some commands such as Rebuild, Fair, 
and Smooth offer some automated solutions for redistributing control points over a curve or surface. 
Other commands, such as control point dragging and nudging, HBar, and MoveUVN, let you 
manually control the location of individual or groups of control points. 

Control point visibility 
To edit curves and surfaces by manipulating control points, use the PointsOn (F10) command to 
turn the control points on. 

When you are finished with control-point editing, use the PointsOff command or press Esc to turn 
them off. 

Control points of polysurfaces cannot be turned on for editing. Editing the control points of 
polysurfaces could separate the edges of the joined surfaces creating “leaks” in the polysurface. 

 

http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Explode.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/split.htm
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
http://www.rhino3d.com/5/help/Commands/ChangeDegree.htm
http://www.rhino3d.com/5/help/Commands/Smooth.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Explode.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/split.htm
http://www.rhino3d.com/5/help/Commands/split.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm#Untrim
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
http://www.rhino3d.com/5/help/Commands/Fair.htm
http://www.rhino3d.com/5/help/Commands/HBar.htm
http://www.rhino3d.com/5/help/Commands/MoveUVN.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm#PointsOff
http://www.rhino3d.com/5/help/Popup_Actions/esc_key.htm
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Change control point locations 
When you move control points, the curve or surface changes, and Rhino smoothly redraws it. The 
curve or surface is not drawn though the control points rather it is attracted to the new positions of 
the control point. This allows the object to be smoothly deformed. When control points are on, Rhino’s 
transform commands can manipulate the points. You can also rebuild surfaces to add control points 
and redistribute them. 

Add, delete, or redistribute control points 
Adding control points to a curve gives you more control over the shape of the curve. Manipulating 
control points also lets you remove kinks, make curves uniform, and add or subtract detail. The 
Delete key erases curve control points. This changes the shape of the curve. 

Curve and surface degree 
A polynomial is a function like y = 3x3 –2x + The "degree" of the polynomial is the largest power of 
the variable. For example, the degree of 3x3 –2x + 1 is 3; the degree of –x5 + x2 is 5, and so on. 
NURBS functions are rational polynomials and the degree of the NURBS is the degree of the 
polynomial. From a NURBS modeling point of view, the (degree –1) is the maximum number of 
"bends" you can get in each span. 

For example: 

A degree-1 curve must have at least two control points. 

A line has degree It has zero "bends." 

 
A degree-2 curve must have at least three control points. 

A parabola, hyperbola, arc, and circle (conic section curves) have degree They have one "bend." 

 
A degree-3 curve must have at least four control points. 

A cubic Bézier has degree If you arrange its control points in a zig-zag shape, you can get two 
"bends." 
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Chapter 8: Transforms 
Transforms change the location, rotation, number and shape of whole objects by moving, mirroring, 
arraying, rotating, scaling, shearing, twisting, bending, and tapering. The transform commands do 
not break the objects into pieces or cut holes in them. 

Move 
Use the Move command when you want to move an object a certain distance or if you want to use 
object snaps to place an object accurately. The quickest way is to click the object and drag it. 

To move selected objects small distances, press and hold the Alt key and press an arrow key to 
activate the Nudge feature. 

Move objects by dragging 
You can drag objects to move them. Select an object and drag it. You can drag objects in any 
viewport. In this model, grid snap is set to one-half of the grid spacing. Using grid snap, you should 
be able to line objects up with each other. 

Before you start, set the grid snap so the objects stay lined up with each other. In this model snap is 
set to one grid line. 

Turn on grid snap 

In the status bar, click Grid Snap to turn on the grid snap. 
The status bar is at the bottom of the Rhino window. You will find the Grid Snap pane in a row 
with other modeling aids: Ortho, Planar, and Osnap. 

Grid snap may already be on in your system. Be careful that you do not turn it off instead of on. 

This is an important step. Grid snap only lets you move in certain preset intervals. In this model, 
grid snap is set to one grid line. Grid snap helps you line up your objects. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Drag Objects.3dm and then click the Open button. 

Practice dragging objects 

In the Perspective viewport, select the cone. 
Drag the cone in the Perspective viewport until it lines up with the cylinder. 
The cone moves on the base that is represented by the grid. This base is called a construction 
plane. A construction plane is like a tabletop where you move your objects. Each viewport has its 
own construction plane. When you start Rhino, the Perspective viewports construction plane is 
the same as the Top viewports. 

In the Front viewport, drag the cone to the top of the cylinder. 
Watch what happens in the Perspective viewport. 

There are many times when you have to watch what is happening in other viewports to 
accurately place your objects. 

Move objects vertically 
So far you have probably moved and copied objects in the x,y-direction and then using a different 
viewport to move in the z-direction. You can also press the Ctrl key to move in the z-direction. This is 
called elevator mode. Elevator mode is like Ortho, except the movement is vertical to the active 
construction plane. 

http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Popup_Actions/alt_key.htm
http://www.rhino3d.com/5/help/Options/Modeling_Aids/Nudge.htm
http://www.rhino3d.com/5/help/Commands/Snap.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/User_Interface/Object_Snaps.htm#Osnap
http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/user_interface/cursor_constraints.htm#Elevator_mode
http://www.rhino3d.com/5/help/Commands/Ortho.htm
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To practice using the Ctrl key to move vertically, you are going to move the cones to the tops of the 
cylinders in one step. Using elevator mode to move objects vertically lets you work more in the 
Perspective viewport. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Elevator Mode.3dm and then click the Open button. 

Review the Help topic 

Review the Help topic for the Move command. 

Move the cone 

From the Transform menu, click Move. 
Turn Grid Snap on and Ortho off. 
In the Perspective viewport, select the cone. 

 

At the Point to move from... prompt, click the point at the center of the cone. 

 

At the Point to move to prompt, drag the cone to the center of the cylinder and click. 

 

Hold the Ctrl key, click and drag the cone up to the top of the cylinder in the Perspective 
viewport. 

http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
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Release the left mouse button, and then release the Ctrl key and click to finish the move. 

 

Copy 
The Copy command makes copies of objects. 

Some transform commands like Rotate, Rotate3D, and Scale have a Copy option. This lets you 
create a copy of the object as you rotate or scale it. 

To copy objects by dragging, drag the objects and hold the Alt key . 

To create more objects, copy the shapes. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Copy Objects.3dm and then click the Open button. 
Most Rhino commands are arranged in the menus. In this exercise, practice starting a command 
from the menu. 

Review the Help topic 

Review the Help topic for the Copy command. 

Practice copying objects 

From the Transform menu, click Copy. 
Select the cone. 
At the Point to copy from prompt, click somewhere in the Top viewport. 
It usually helps to click a spot that relates to the object, such as the middle. 

At the Point to copy to prompt, click where you want the first copy. 
Zoom in or out if you like. 

To zoom, hold the Ctrl key and drag with the right mouse button or use the wheel on your 
mouse. 

At the next Point to copy to prompts, click other places to make some copies of the box. 
When you have enough copies, press Enter. 

http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/Commands/Rotate.htm
http://www.rhino3d.com/5/help/Commands/Rotate3D.htm
http://www.rhino3d.com/5/help/Commands/scale.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Copy.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Rotate 
The Rotate command rotates an object in relation to the construction plane. 

In the next exercise, you will learn a new basic Rhino command: Rotate. The Rotate command 
rotates an object around a center point. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Rotate-Scale.3dm and then click the Open button. 

 

Practice rotating objects. First, rotate the long box in the Top viewport, and then rotate the half-
cylinder in the Right viewport. 

Review the Help topic 

Review the Help topic for the Rotate command. 

Rotate an object 

From the Transform menu, click Rotate. 
On the status bar, turn Grid Snap on. 
In the Top viewport, select the long box as shown in the illustration below. 

 

At the Center of rotation... prompt, click the lower left corner of the box. 

 

At the Angle or first reference point...prompt, drag the cursor to the right and click. 
Grid Snap will help you keep the tracking line straight. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Rotate.htm
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Or, at the command prompt, type 90. 

If you know the angle you want, you can type it instead of dragging with the mouse. 

At the Second reference point... prompt, drag the cursor to rotate the box as shown in the 
illustration below, and click. 

 

From the Edit menu, click Undo to return the box to its original position. 

Rotate the half cylinder 
In the Top and Front viewports, you cannot really see the half cylinder because from your viewpoint, 
it looks nearly like a box. You will notice, however, that it has a different pattern of lines in its 
wireframe display. You can see it best in the Right viewport. 

To rotate the half cylinder 

In the Right viewport, zoom in so you can identify the half cylinder. 

 

In the Right viewport, select the half cylinder as shown in the illustration below. 

 

From the Transform menu, click Rotate. 
Or press Enter, the Spacebar, or click the right mouse button to repeat the command. 

At the Center of rotation...prompt, click the lower right corner of the half cylinder. 

http://www.rhino3d.com/5/help/Commands/Rotate.htm
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At the Angle or first reference point... prompt, drag the cursor to the left and click. 
Grid Snap will help you keep the tracking line straight. 

 

Or at the command prompt, type 90. 

At the Second reference point... prompt, drag the cursor to rotate the half-cylinder as shown 
in the illustration below, and click. 

 

From the Edit menu, click Undo to return the half cylinder to its original position. 

Scale 
Scale commands give you control over the direction of the scale. You can resize objects uniformly in 
one, two, or three directions, or scale an object with a different scale factor in each direction. 

You can change the size of objects in all three dimensions, but for now you are going to learn how to 
scale objects in only one direction. This is good for making objects longer or shorter. It is not good for 
objects that have circular shapes that you want to maintain. For practice, you will scale the short 
prism shape and the long box. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Rotate-Scale.3dm and then click the Open button. 

http://www.rhino3d.com/5/help/Commands/Undo.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
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Review the Help topic 

Review the Help topic for the Scale1D command. 

Scale the prism 

From the Transform menu, click Scale, and then click Scale 1-D. 
On the status bar, confirm that Grid Snap is on. 
In the Perspective viewport, zoom in on the small prism. 

 

Select the prism shape. 
At the Origin point... prompt, click the corner of the prism as shown in the illustration below. 

 

The origin point is the base point from which the object will be scaled. It is like an anchor point. 
The object will grow or shrink around this point. 

To scale an object, you must first show an original size and then show a new size. You are going 
to drag the cursor and click to the show the original scale, and then drag the cursor and click 
again to show the new scale. 

At the Scale factor or first reference point... prompt, click the corner of the prism as shown 
in the illustration below. 
This establishes the first reference point. 

 

http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Scale1D.htm
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At the Second reference point... prompt, drag the cursor. 
The object grows in the direction you drag the cursor. 

Click to set the second reference point. 
Use Grid Snap to control the reference point placement. 

 

From the Edit menu, click Undo to return the prism to its original size. 

Mirror 
The Mirror command reverses the orientation of the object across a defined line. By default, a copy 
is made. 

You already know how to move, copy, scale, and rotate objects. In this exercise, you are going to 
practice another basic editing command: Mirror. The Mirror command makes a mirror image copy of 
the object. Objects are mirrored around a plane that is perpendicular to the active construction plane. 
You specify the planes direction with the mirror line. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Mirror Objects.3dm and then click the Open button. 

 

Review the Help topic 

Review the Help topic for the Mirror command. 

Mirror an object 

From the Transform menu, click Mirror. 
On the status bar, turn Grid Snap and Ortho on. 
Select the object. 

 

http://www.rhino3d.com/5/help/Commands/Undo.htm
http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Mirror.htm
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At the Start of mirror plane... prompt, in the Top or Front viewport, click to the right of the 
face as shown in the illustration below. 

 

At the End of mirror plane... prompt, drag the line toward the bottom of the screen... 

 

... and click to end the mirror plane. 

 

Mirror the objects in a different direction 
This time when you mirror the objects, the heads will be spherical instead of half-spheres. 

To mirror the objects 

Select both objects. 
Use a crossing or window. 

From the Transform menu, click Mirror. 

 

At the Start of mirror plane... prompt, in the Front viewport, click on the red construction 
plane axis line. 
Note: You must use the Front viewport. 

Look at the status bar coordinates to be sure that the z-coordinate is 0.000. 

http://www.rhino3d.com/5/help/Commands/Mirror.htm
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At the End of mirror plane... prompt, drag the line to the right and click to end the mirror 
plane. 

 

The mirror makes the faces into two trimmed spheres. 

 

Rotate the view in the Perspective viewport. 

 

Orient 
The Orient commands combine move or copy, scale, and rotate operations to help you position and 
size objects in one command. 

See the Rhino Help topics for more information. 

Array 
The Array commands copy objects into evenly spaced rows and columns or around a circle. 

See the Rhino Help topics for more information. 

http://www.rhino3d.com/5/help/Commands/orient.htm
http://www.rhino3d.com/5/help/
http://www.rhino3d.com/5/help/Commands/Array.htm
http://www.rhino3d.com/5/help/
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Chapter 9: Curve and Surface Analysis 
Since Rhino is a mathematically accurate NURBS modeler, tools that provide accurate information 
about the objects are provided. 

Measure distance, angle, and radius 
Some analysis commands provide information about location, distance, angle between lines, and 
radius of a curve. For example: 

Distance displays the distance between two points. 
Angle displays the angle between two lines. 
Radius displays the radius of a curve at any point along it. 
Length displays the length of a curve. 

Curve and surface direction 
Curves and surfaces have a direction. Many commands that use direction information display 
direction arrows and give you the opportunity to change (flip) the direction. 

The Dir command displays the direction of a curve or surface and lets you change the direction. 

The illustration shows the curve direction arrows. If the direction has not been changed, it reflects the 
direction the curve was originally drawn. The arrows point from the start of the curve toward the end 
of the curve. 

 
The Dir command also displays surface u-, v-, and normal direction. Surface normals are represented 
by arrows perpendicular to the surface, and the u- and v-directions are indicated by arrows pointing 
along the surface. Closed surfaces always have the surface normals pointing to the exterior. 

The Dir command can change the u-, v-, and normal-directions of a surface. This direction can be 
important if you are applying textures to the surface. 

 

Curvature 
Curve analysis tools let you turn on a graph showing the direction perpendicular to the curve at a 
point and the amount of curvature, display a curvature circle, test the continuity between two curves 
and the intervals of overlap between the two curves. 

The CurvatureGraph command displays a curvature graph on curves and surfaces. The lines on the 
graph represent a direction perpendicular to the curve at that point. The length of the line indicates 
the curvature. 

http://www.rhino3d.com/5/help/Commands/Distance.htm
http://www.rhino3d.com/5/help/Commands/Angle.htm
http://www.rhino3d.com/5/help/Commands/Radius.htm
http://www.rhino3d.com/5/help/Commands/Length.htm
http://www.rhino3d.com/5/help/Commands/Dir.htm
http://www.rhino3d.com/5/help/Commands/Dir.htm
http://www.rhino3d.com/5/help/Commands/Dir.htm
http://www.rhino3d.com/5/help/Commands/CurvatureGraph.htm
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Visual surface analysis 
Visual surface analysis commands let you examine surfaces to determine smoothness as determined 
by its curvature, tangency, or other surface properties. These commands use NURBS surface 
evaluation and rendering techniques to help you visually analyze surface smoothness with false color 
or reflection maps so you can see the curvature and breaks in the surface. 

Environment map 
The EMap command displays a bitmap on the object so it looks like a scene is being reflected by a 
highly polished metal. Tool helps you find surface defects and validate your design intent. 

The fluorescent tube environment map simulates tube lights shining on a reflective metal surface. 

 

Curvature analysis 
The CurvatureAnalysis command analyzes surface curvature using false-color mapping. It analyzes 
Gaussian curvature, mean curvature, minimum radius of curvature, and maximum radius of 
curvature. 

 

Zebra analysis 
The Zebra command displays surfaces with reflected stripes. This is a way to visually check for 
surface defects and for tangency and curvature continuity conditions between surfaces. 

 

Draft angle analysis 

http://www.rhino3d.com/5/help/Commands/EMap.htm
http://www.rhino3d.com/5/help/Commands/CurvatureAnalysis.htm
http://www.rhino3d.com/5/help/Commands/Zebra.htm
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The DraftAngleAnalysis command displays by false-color mapping the draft angle relative to the 
construction plane that is active when you start the command. 

The pull direction for the DraftAngleAnalysis command is the z-axis of the construction plane. 

 

Edge evaluation 
Geometry problems such as Boolean or join failures can be caused by edges on surfaces that have 
become broken or edges between surfaces that have been moved through point editing so they 
create holes. An edge is a separate object that is part of the surface’s boundary representation. 

The ShowEdges command highlights all the edges of the surface. 

 

Find open edges 
A polysurface may look closed, but the Properties command may tell you that it is open. Some 
operations and export features require closed polysurfaces, and a model using closed polysurfaces is 
generally higher quality than one with small cracks and slivers. 

Rhino provides a tool for finding the unjoined or “naked” edges. When a surface is not joined to 
another surface, it has naked edges. Use Properties command to examine the object details. A 
polysurface that has naked edges lists as an open polysurface. Use the ShowEdges command to 
display the unjoined edges. 

Other edge tools let you split an edge, merge edges that meet end-to-end, or force surfaces with 
naked edges to join. You can rebuild edges based on internal tolerances. Other edge tools include: 

SplitEdge splits an edge at a point. 
MergeEdge merges edges that meet end to end. 
JoinEdge forces unjoined (naked) edges to join nearby surfaces. 
RebuildEdges redistributes edge control points based on internal tolerances. 

Diagnostics 
Diagnostic tools report on an object’s internal data structure and select objects that may need repair. 
The output from the List, Check, SelBadObjects, and Audit3dmFile commands is normally most 
useful to a Rhino programmer to diagnose problems with surfaces that are causing errors. 

http://www.rhino3d.com/5/help/Commands/DraftAngleAnalysis.htm
http://www.rhino3d.com/5/help/Commands/ShowEdges.htm
http://www.rhino3d.com/5/help/Commands/SplitEdge.htm
http://www.rhino3d.com/5/help/Commands/MergeEdge.htm
http://www.rhino3d.com/5/help/Commands/JoinEdge.htm
http://www.rhino3d.com/5/help/Commands/RebuildEdges.htm
http://www.rhino3d.com/5/help/Commands/List.htm
http://www.rhino3d.com/5/help/Commands/Check.htm
http://www.rhino3d.com/5/help/Commands/Selection_Commands.htm#SelBadObjects
http://www.rhino3d.com/5/help/Commands/audit.htm#Audit3DMFile_command
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Chapter 10: Organizing the Model 
Rhino offers aids to organizing your work: layers, groups, blocks, and worksessions. Each method 
offers a different approach to model organization. Using layers lets you assign a layer designation to 
objects. Groups associate objects so they can be selected as one. Blocks let you store and update an 
association of objects. Worksessions let you work on a part of a project while using other models in 
the project as references. 

Layers 
Layers are a way of grouping objects and applying certain characteristics to all objects that have that 
layer assignment. There are two “mental models” you can use when you think of layers—layers can 
be thought of either as a “storage location” for the objects or as a way to assign a set of 
characteristics or properties to objects. 

Layer states include a layer name, the color used to display the objects, and the on/off and 
locked/unlocked status of all the objects on a layer. Objects on layers that are off are not visible in 
the model. Objects on locked layers cannot be selected but can be snapped to. Objects are always 
created on the current layer. This layer assignment can be changed later. 

To accomplish the most common tasks related to layers, click the Layer pane in the status bar to 
display the popup layer list. You can set the current layer; change the on/off, locked/unlocked state; 
and the layer color. In addition, right-click the layer name to create a new layer, rename a layer, 
delete the selected layer, select objects on the selected layer, change objects to the selected layer, 
and copy objects to the selected layer. 

Accomplish more detailed layer management with the Layers panel. Right-click the Layer pane to 
open the Layers panel. The Layers panel sets the current layer, locks and unlocks layers, turns 
layers on and off, changes the layer color and sets the layer render material. You can create new 
layers, delete layers, move layers up or down in the layer list, filter the layer list, set the current layer 
to match an object in the model, change objects to a selected layer, select all layers, and invert the 
selection. 

The SelLayer command selects all objects on a layer. 

Groups 
A group is a collection of objects that select as one for moving, copying, rotating, or other transforms 
and applying properties such as object color. Grouping objects assigns a group name to each object 
that is displayed as a part of its properties. Objects with the same group name belong to the same 
group. 

Group groups objects for selection. A group can contain one or more sub-groups. 
Ungroup destroys the group. 
SetGroupName changes the name assigned by default. Naming different groups to the same 
name combines those groups into one. 
AddToGroup and RemoveFromGroup add and remove objects from groups. 
SelGroup selects groups by name. 

Blocks 
A block is another way of associating objects together to form a single object. The Block command 
creates a block definition in the current model. The Insert command places instances of this block 
definition in your model. You can scale, copy, rotate, array, and otherwise transform block instances 
in the model. If you edit the block definition, all instances of the block are changed to this new 
definition. Blocks can streamline modeling, reduce model size, and promote standardization of parts 
and details. 

http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Selection_Commands.htm#SelLayer
http://www.rhino3d.com/5/help/Commands/Group.htm
http://www.rhino3d.com/5/help/Commands/Group.htm#Ungroup
http://www.rhino3d.com/5/help/Commands/Group.htm#SetGroupName
http://www.rhino3d.com/5/help/Commands/Group.htm#AddToGroup
http://www.rhino3d.com/5/help/Commands/Group.htm#RemoveFromGroup
http://www.rhino3d.com/5/help/Commands/Selection_Commands.htm#SelGroup
http://www.rhino3d.com/5/help/Commands/block.htm
http://www.rhino3d.com/5/help/Commands/Insert.htm
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Multiple instances of block can be located, scaled, and rotated into a model with the Insert 
command. Block definitions are created with the Block or Insert command. Materials and other 
object properties on block instances are determined by the component objects. 

Exploding a block instance places the block geometry using the instance location, scale, and rotation. 
To redefine a block, use the BlockEdit command, to edit the geometry. 

The BlockManager command displays a dialog box that lists all the block definitions in the model. 
Use the Block Manager dialog box to view block properties, export a block definition to a file, delete 
a block definition and all its instances, update a block definition from a file, find out what blocks are 
nested in other blocks, and count the number of block instances in the model. 

Worksessions 
The Worksession command lets many users work on a large project by managing many files. Each 
user can edit a different file in the project and at the same time see the related portions of the 
project. By refreshing as needed, each user can see the current version of the related files in the 
projects. Only one user can have a file open for editing, but many users can see it. 

Rhino worksessions let you “attach” external files to your current work environment. Attached 
geometry cannot be edited (move, scale), but it can be used for input to creation commands (copy, 
extrude). 

http://www.rhino3d.com/5/help/Commands/Insert.htm
http://www.rhino3d.com/5/help/Commands/block.htm
http://www.rhino3d.com/5/help/Commands/Insert.htm
http://www.rhino3d.com/5/help/Commands/BlockEdit.htm
http://www.rhino3d.com/5/help/Commands/blockmanager.htm
http://www.rhino3d.com/5/help/Commands/Worksession.htm


 

52 

Chapter 11: Annotation 
Rhino provides the ability to add notation to your model in the form of dimensions, leaders, and text 
blocks. These appear as objects in the model. A different form of notation, the annotation dots and 
arrowheads, always display facing towards the view plane. 

In addition, you can add notes to the model. Notes do not appear in the model, but display in a 
separate window. 

Dimensions 
You can dimension objects in your model, with your choice of font, units display, decimal precision, 
text and arrow size, and text alignment. After dimensions are placed, you can select all dimensions, 
edit dimension text, turn control points on to move dimension elements, and delete dimensions. You 
can place horizontal, vertical, aligned, rotated, radial, diameter, and angle, text blocks, leaders, and 
create a 2-D hidden line drawing. 

Dimensions are not associative. Changing your geometry will not update the dimension unless the 
dimension was drawn with history enabled. Changing the dimension will not update your geometry. 

The Dim command places horizontal and vertical dimensions depending on the direction you pick the 
points. 

Dimensions are created using the current dimension style. Create new dimension styles to control 
text size and font, and other dimension properties. Use the settings in the Document Properties 
window to create new styles and set the properties of existing styles. 

 

Text 
The Text command places annotation text in your model. 

 

Leaders 
The Leader command draws an arrow leader. 

 

http://www.rhino3d.com/5/help/Commands/Dim.htm
http://www.rhino3d.com/5/help/DocumentProperties/Dimensions_Style.htm
http://www.rhino3d.com/5/help/Commands/Text.htm
http://www.rhino3d.com/5/help/Commands/Leader.htm
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Dots 
The Dot command places a text dot. 

Dots are always parallel to the view. There are no controls for the dot size. Dots are displayed in the 
layer color. Dot size is constant on the screen. As you zoom in and out, the dot displays the same 
size. 

 

Hidden line removal 
The Make2D command creates curves from the selected objects as silhouettes relative to the active 
view. The silhouette curves are projected flat and then placed on the world x,y-plane. 

The command options create the 2-D drawing from the current view, current construction plane, 
create a four-view layout using US or European projection angles, set layers for the hidden lines, and 
display tangent edges. 

 

Notes 
The Notes command provides a means of storing text information in your model file. You can type 
information directly into the Notes text box. If you leave the Notes box displayed when you close 
the model file, it will display the next time the file is opened. 

http://www.rhino3d.com/5/help/Commands/Dot.htm
http://www.rhino3d.com/5/help/Commands/Make2D.htm
http://www.rhino3d.com/5/help/Commands/Notes.htm
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Chapter 12: Render 
In addition to shaded previews, Rhino provides full-color rendering with lights, transparency, 
shadows, textures, and bump mapping. If you want to create photo-realistic renderings, use a full-
featured rendering program, such as Flamingo. 

Objects will render white until you add render color, highlight, texture, transparency, and bumps. 
These attributes are controlled through the Properties panel, Material page. 

 

The process needed to render scenes consists of four basic steps: 

Add lighting 
Assign materials 
Set up the environment and ground plane 
Render 

Although the steps do not have to be done in this order, using this method seems to make setting up 
a scene more efficient. To improve quality, repeat these steps until the image looks right to you. 

Lights 
In every Rhino rendering there are light sources that Rhino uses to calculate how the objects are to 
be illuminated. The Spotlight, DirectionalLight, LinearLight, PointLight, RectangularLight, and 
Sun commands let you put lights into your model.  If you do not add any light sources to your scene, 
the default light is used. The default light is a directional light with parallel rays that acts as though 
you have a lamp shining over your left shoulder. 

Materials 
Materials specify the color, finish, transparency, texture, and bump for use by the built-in Rhino 
renderer. 

Assign materials to layers 

In the Layers panel, select one or more layer names, and click in the Material column. 
In the Layer Material dialog box, set up material properties. 

Assign materials to objects 

Select an object. 
On the Edit menu, click Object Properties. 
In the Properties panel, Material page, set up material properties. 

Environment 
Environments describe the space around the model. This space is reflected in objects and can provide 
overall lighting. 

http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Properties/material.htm
http://www.rhino3d.com/5/help/Commands/Lights.htm#Spotlight
http://www.rhino3d.com/5/help/Commands/Lights.htm#DirectionalLight
http://www.rhino3d.com/5/help/Commands/Lights.htm#LinearLight
http://www.rhino3d.com/5/help/Commands/Lights.htm#PointLight
http://www.rhino3d.com/5/help/Commands/Lights.htm#RectangularLight
http://www.rhino3d.com/5/help/Commands/Sun.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Properties/material.htm
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Set up the rendering environment 

The rendering properties include environment settings like background color and image. 

Open the Environment Editor panel. 
Set up environment properties. 

Ground Plane 
The ground plane provides an infinite horizontal platform for the image that stretches to the horizon 
in all directions positioned at a defined elevation. A ground plane renders much faster than using a 
surface as a background. Any material can be assigned to the ground plane. 

Turn on a ground plane 

Open the Ground Plane panel. 
Set up ground plane properties. 

Render and save 
On the Render menu, click Render. 
In the Render Window, on the File menu, click Save As. 

http://www.rhino3d.com/5/help/Commands/EnvironmentEditor.htm
http://www.rhino3d.com/5/help/Commands/GroundPlane.htm
http://www.rhino3d.com/5/help/Commands/Render.htm
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Chapter 13: Pull Toy Tutorial - Solids and Transforms 
This tutorial demonstrates using solid primitives and simple transforms. 

You will learn how to: 

Enter coordinates to place points exactly. 
Draw a free-form curve and polygon. 
Create a pipe along a curve. 
Use a polar array to copy objects in a circular pattern. 
Extrude a curve to create a surface. 
Use planar mode. 

 

Enter coordinates 
When you pick a point with the mouse, the point lies on the construction plane of the active viewport 
unless you use a modeling aid such as object snap or elevator mode. When Rhino prompts for a 
point, you can enter x-, y-, and z-coordinates instead of picking a point. Each viewport has its own 
construction plane on which its x- and y-coordinates lie. The z-coordinate for the active viewport is 
perpendicular to the x-y plane. 

The grid is a visual representation of the construction plane. The intersection of the dark red and 
green lines shows the location of the origin point (x=0, y=0, z=0) of the coordinate system. 

Draw the pull toy body 
This exercise uses x-, y-, and z-coordinates to accurately place points. When you are to type 
coordinates, type them just as they are shown in the manual. The format is x,y,z. For example, type 
1,1,4. You must type the commas. This sets the point at x=1, y=1, and z=4 in the active viewport. 

Whenever you type points, look in all viewports at where the point is placed so you can start getting 
an idea of how coordinate entry works. 

Note: Pay close attention to the viewport required in each instruction. 

Start the model 

Begin a New model. 
In the Template File dialog box, select Small Objects - Centimeters.3dm, and click Open. 

Draw an ellipsoid 

Turn on Ortho. 
On the Solid menu, click Ellipsoid > From Center. 
With the Top viewport active, at the Ellipsoid center… prompt, type 0,0,11, and press Enter. 
This places the center point of the ellipsoid at x=0, y=0, and z=1 Look at the point in the 
perspective viewport. 

At the End of first axis… prompt, type 15, and press Enter. 

http://www.rhino3d.com/5/help/Commands/New.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Move the cursor to the right to show the direction and click. 

 
At the End of second axis prompt, type 8, and press Enter. 
Move the cursor up to show the direction and click. 
This sets the width of the ellipsoid. 

 
At the End of third axis prompt, type 9, and press Enter. 
You now have an egg shape that has different dimensions in all three directions. 

 
Rotate the perspective viewport so you are looking along the x-axis as illustrated. 
Turn on Shaded display mode in the Perspective viewport. 

 

Draw the axles and wheel hubs 
The axles and wheel hubs are cylinders. The axles are long, thin cylinders, and the wheel hubs are 
short, fat cylinders. You are going to make one axle and one complete wheel. You will then mirror the 
complete wheel to the other side. You can then either mirror or copy the complete axle and wheel set 
to the front of the toy. 

Create the axle 

On the Solid menu, click Cylinder. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Commands/cylinder.htm
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With the Front viewport active, at the Base of cylinder… prompt, type 9,6.5,10, and press 
Enter. 
At the Radius… prompt, type .5, and press Enter. 
At the End of cylinder prompt, type -20, and press Enter. 

 

Create a wheel hub 

On the Solid menu, click Cylinder. 
With the Front viewport active, at the Base of cylinder… prompt, type 9,6.5,10, and press 
Enter. 
At the Radius… prompt, type 4, and press Enter. 
At the End of cylinder prompt, type 2, and press Enter. 

 

 

Draw the lug nuts 
You will make the lug nuts by extruding a hexagonal polygon curve. 

Create a hexagon 

On the Curve menu, click Polygon > Center, Radius. 
At the Center of inscribed polygon ( NumSides=4…) prompt, type 6, and press Enter. 
In the Front viewport, at the Center of inscribed polygon… prompt, type 9,8,12, and press 
Enter. 
This will place the polygon right on the surface of the wheel hub. 

At the Corner of polygon… prompt, type .5, and press Enter. 
In the Front viewport drag the cursor as illustrated, and click to position the hexagon. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/cylinder.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Polygon.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Make a solid from the polygon 

Select the hexagon you just created. 
On the Solid menu, click Extrude Planar Curve > Straight. 
At the Extrusion distance ( Direction BothSides=No  Solid=Yes  DeleteInput=Yes 
 ToBoundary  SplitAtTangents=No  SetBasePoint) prompt, notice the command-line 
options. 
Many commands have options. You will learn how to change and use them as you learn to use 
the commands. Take a moment and look at the options available for the ExtrudeCrv command. 

Press F1 to look at the Help topic for this command. The Help topic explains the options. 

At the Extrusion Distance… prompt, type -.5, and press Enter. 
Notice the negative number. If you type a positive number at this point, the nuts will be buried 
in the wheel hub. You want them to stick out. 

 

Array the lug nuts 
To create the lug nuts on the first wheel, you are going to use a polar (circular) array. An array is a 
set of copies of an object. You control how the copies are made. A polar array copies the objects 
around a central point. The objects are rotated as they are copied. 

Array the nuts 

Select the lug nut. 
On the Transform menu, click Array > Polar. 
The hexagon curve is still there, so be sure you select the extruded lug nut. (The selection menu 
will list it as a closed extrusion.) 

With the Front viewport active, at the Center of polar array prompt, use the Cen object snap 
to snap to the center of the hub. 
At the Number of elements… prompt, type 5, and press Enter. 
At the Angle to fill <360> prompt, press Enter. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/arraypolar.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm


Chapter 13: Pull Toy Tutorial - Solids and Transforms 

61 

 

Draw the tires 
The tires are a solid form called a torus, which looks like a donut. When you are drawing a torus, the 
first radius is the radius of a circle around which the “tube” is drawn. The second radius is the radius 
of the tube itself. 

To draw the tires, you will draw the center of the torus tube a bit larger than the diameter of the 
wheel hub. The tube itself is slightly larger than the hub. This makes it dip into the hub. 

Create a torus for the tires 

On the Solid menu, click Torus. 
In the Front viewport, at the Center of torus… prompt, type 9,6.5,11, and press Enter. 
This places the center of the torus at the same point as the center of the wheel hub. 

At the Radius… prompt, type 5, and press Enter. 
This makes the center of the torus tube one unit larger than the wheel hub. 

At the Second radius… prompt, type 1.5, and press Enter. 
This makes the hole .5 units smaller than the wheel hub. 

 

Mirror the wheels 
Now that you have a whole wheel created, you can use the Mirror command to create the other 
three. 

Mirror the wheel to the other side 

In the Top viewport, use a window to select the wheel as illustrated. 
On the Transform menu, click Mirror. 
At the Start of mirror plane… prompt, type 0,0,0, and press Enter. 

http://www.rhino3d.com/5/help/Commands/Torus.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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At the End of mirror plane… prompt, with Ortho on, drag to the right in the Top viewport as 
illustrated and click. 

 

Mirror the front wheels and axle 

In the Top viewport, use a window to select the wheels and axle as illustrated. 
On the Transform menu, click Mirror. 
At the Start of mirror plane… prompt, type 0,0,0, and press Enter. 

 
At the End of mirror plane… prompt, with Ortho on, drag down in the Top viewport as 
illustrated and click. 

 

Draw the eyes 
You are going to draw a sphere for an eye and a smaller sphere for the pupil. 

Create an eye using a sphere 

On the Solid menu, click Sphere > Center, Radius. 
At the Center of sphere… prompt, in the Top viewport, type -12,-3,14, and press Enter. 
At the Radius… prompt, type 3 and press Enter. 

http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Sphere.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Repeat the Sphere command. 
At the Center of sphere… prompt, in the Top viewport, type -13,-4,15, and press Enter. 
At the Radius… prompt, type 2 and press Enter. 
Change the color of the pupil to black. 

 

Mirror the eye 

In the Top viewport, use a window to select the eye as illustrated. 
On the Transform menu, click Mirror. 

 
At the Start of mirror plane… prompt, type 0,0,0, and press Enter. 
At the End of mirror plane… prompt, with Ortho on, drag to the left in the Top viewport as 
illustrated and click. 

 
Right-click the Perspective viewport title. 
On the Viewport title menu, click Rendered. 

 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
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Make the pull cord 
To make the cord, you are going to draw a freehand curve using elevator and planar mode. When the 
curve is complete, use the Pipe command to make it a thick solid. 

Set up the view 

Zoom out in all the viewports; you are going to need some space to work. 
On the status bar, turn Planar mode on, and turn Ortho off. 
In the Osnap dialog box, click Disable to turn off all object snaps. 

Create the pull cord at the front of the toy 

On the Curve menu, click Free-form > Control Points. 
At the Start of curve… prompt, in the Top viewport, hold Ctrl to activate elevator mode and 
click near the front end of the ellipsoid. 

 
Move the cursor to the Front viewport, drag the marker near the end of the ellipsoid, and click. 

 
At the Next point… prompt, click to the left of the ellipsoid in the Top viewport. 

 
Planar mode keeps successive points at the same construction plane elevation. Planar mode can 
be overridden with elevator mode or object snaps. Watch the curve in the Top and Front 
viewports. 

At the Next point… prompt, use elevator mode to add another point in the Top viewport. 

 

http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Popup_Actions/ctrl_key.htm
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At the Next point… prompts, turn off Planar mode and click several more points in the Top 
viewport to create a curved line. 

 
Notice that the points are projected to the Top construction plane. 

 

Make the cord handle 

Draw an Ellipsoid to represent a handle at the end of the curve. 
In the Osnap dialog box, clear the Disable checkbox and use the End object snap to snap the 
ellipsoid to the end of the curve. 

 

Thicken the curve with a pipe 

Select the curve you just made at the front of the pull toy. 
On the Solid menu, click Pipe. 
At the Start radius… prompt, type .2, and press Enter. 
At the End radius… prompt, press Enter. 
At the Point for next radius prompt, press Enter. 
The pipe will be the same diameter for the full length of the curve. 

 

http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Chapter 14: Flashlight Tutorial - Revolve Curves 
Drawing objects using solid primitives, as you have done in the previous exercises, limits the shapes 
you can create. Creating surfaces from curves and joining the surfaces together allows you much 
greater freedom. 

This tutorial introduces the concept of drawing curves and one method of creating surfaces from 
those curves. This exercise creates a revolved surface from a profile curve. Revolving curves is a 
good method for creating tubular shapes like vases, wineglasses, and chair legs. 

 

You will learn how to: 

Draw free-form curves based on an existing object. 
Edit control points. 
Revolve surfaces around an axis. 
Assign properties and render. 

You are going to use a basic flashlight as a guide for drawing the curves you will need for the new 
model. Using the basic flashlight gives you a frame of reference for deciding about the size and shape 
of the object. If you did not work through this tutorial or save your model, a completed model is 
provided. 

To get started 

On the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Open the model file Flashlight.3dm. 

Set up the model 
You are going to trace around the old flashlight. To make this easier, you will lock the objects. When 
objects are locked, you can see them and snap to them, but you cannot select them. This keeps the 
objects from interfering when you want to select things close by. You can still use object snaps to 
snap to locked objects. You will then create some curves and revolve them to make the new 
flashlight. 

Lock the flashlight objects 

Select all the objects. 
Press Ctrl + A to select all the objects in the model. 

On the Edit menu, click Visibility > Lock. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/Commands/Selection_Commands.htm#SelectAll
http://www.rhino3d.com/5/help/Commands/Lock.htm
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Draw a centerline 
Draw a construction centerline through the center of the old flashlight. 

Draw the construction centerline 

On the Curve menu click Line > Single Line. 
At the Start of line… prompt, use the Center object snap to place the start of the line at the 
center of the flashlight base. 
At the End of line… prompt, turn Ortho on, and draw the line through the exact center of the 
old flashlight. 

 

Draw the body profile curve 
You are going to draw a profile curve that you will use to revolve to create the flashlight body. A 
profile curve defines a cross-section of one half of the part. 

Draw the body curve 

On the status bar, click the Layer pane and make the layer Free Form Body current. 
On the Curve menu, click Free-Form > Control Points. 
At the Start of curve… prompt, in the Front viewport, start drawing a curve around the 
flashlight body as illustrated. 

 
Use the End object snap to start the curve at the end of the construction center line. 

Use the Near object snap to end the curve on the construction center line. 

Starting and ending the curve exactly on the line is important so that later when you revolve the 
curve to create a solid, there will be no gaps or overlapping parts. 

http://www.rhino3d.com/5/help/Commands/Line.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm


Rhinoceros User's Guide 

68 

 
When drawing the curve, use Ortho to control the first two points on the curve. If the first two 
points and the last two points are placed in a straight line, the curve will start and end tangent 
to that line. 

 
When you have placed the last control point, press Enter to finish drawing the curve. 
To place the last two points in a straight line with each other, use Grid Snap, Ortho, or Perp 
object snap. 

Draw the lens profile curve 
Make another profile curve for the lens. 

Create the lens 

On the Curve menu, click Free-Form > Control Points. 
At the Start of curve… prompt, in the Front viewport, place the first control point of the lens 
profile. 
Use the Near object snap to start and end the curve on the construction centerline. 

Place control points in the upper part of the lens curve so it crosses the body profile curve. 

 

Get the old flashlight out of your way 

On the Edit menu, click Visibility > Unlock. 
Select all the objects except the two profile curves you just drew and the switch sphere. 
On the Edit menu, click Visibility > Hide. 

http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Snap.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/Lock.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm
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Build the flashlight body 
To make the body, you will revolve the profile curve 360 degrees. You will use the endpoint of the 
curve and ortho to establish the rotation axis. 

Create the flashlight body 

On the Surface menu, click Revolve. 
At the Select curve to revolve prompt, select the body profile curve. 
At the Start of revolve axis prompt, snap to one endpoint of the body curve. 
At the End of revolve axis prompt, turn Ortho on, and specify the revolve axis line as 
illustrated. 

 
In the Start angle... prompt, click the FullCircle option. 

 

Create the lens 
Now revolve the lens profile curve in the same way as the body. 

Revolve the lens profile curve 

On the Surface menu, click Revolve. 
At the Select curve to revolve prompt, select the lens profile curve. 
At the Start of revolve axis prompt, use End object snap to locate the endpoint of one of the 
curve profiles. 
At the End of revolve axis prompt, turn Ortho on, and draw the revolve axis line as illustrated. 

http://www.rhino3d.com/5/help/Commands/Revolve.htm
http://www.rhino3d.com/5/help/Commands/Revolve.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
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In the Start angle... prompt, click the FullCircle option. 
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Chapter 15: Headphone Tutorial - Sweep, Loft, and Extrude 
This tutorial demonstrates creating surfaces from profile curves using lofts, sweeps, and extrudes. 

You will learn how to: 

Create a surface from a planar curve. 
Loft, revolve, sweep, and extrude surfaces. 
Cap planar holes to create a solid. 
Create solid pipes. 
Mirror objects. 
Use layers. 
Use object snaps. 

 

To open the headphone model 

On the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Open the model file Headphone.3dm. 

Create the speaker shell 
The speaker shell is created using a lofted surface, a one-rail sweep, a solid extrusion of a planar 
curve, and a surface fillet. The resulting geometry is joined into one solid. 

Loft curves to create a surface 

One way to create a surface is to use existing curves as a guide. When lofting through curves, the 
curves are used as a guide for creating a smooth surface. 

Turn on Shaded mode in the Perspective viewport. 
Select the three circular curves, with a crossing selection as illustrated. 

 
On the Surface menu, click Loft. 
At the Adjust curve seams… prompt, note the display of the curve direction arrows at the 
seam points, and press Enter 
In this model, they are nicely lined up for you, so you do not need to adjust them. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Loft.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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In the Loft Options dialog box, click OK to create the loft. 

 

Make a solid cylinder by extruding a circular curve 

Extrude the curve in the center to make a magnet housing. 

Select the curve at the center of the lofted surface. 
On the Solid menu, click Extrude Planar Curve > Straight. 

 
At the Extrusion Distance… prompt, type -2 and press Enter. 
This makes a solid cylinder for the magnet housing that is two units thick and extends in the 
negative direction from the original curve. 

 

Reset the view 

Select the cylinder. 
On the View menu, click Zoom > Zoom Selected. 

Extract the bottom surface 

The cylinder you just created is a closed polysurface (solid) consisting of three joined surfaces—the 
side, top, and bottom. To remove the bottom, extract the face. 

From the Solid menu, click Extract Surface. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Commands/ExtractSrf.htm
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At the Select surfaces to extract… prompt, select the surface as illustrated and press Enter. 

 
Press the Delete key. 

 

Fillet the edge of the cylinder surface 

On the Solid menu, click Fillet Edge > Fillet Edge. 
The current radius setting should be 1. 

At the Select edges to fillet… prompt, select the edge at the top of the cylinder press Enter. 

 

At the Select fillet handle to edit prompt, press Enter. 

 

Join the surfaces 

Surfaces that share an edge can be joined into a polysurface. You will join all the surfaces. Since the 
faces are sometimes hard to see, use two viewports to select them all. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/FilletEdge.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Select the surface and the polysurface. 
From the Edit menu, click Join. 
To join surfaces, you must select surfaces that are adjacent to each other and the edges must 
match. 

 

Create the padding and cover 
Sweep a curve around the edge of the speaker cone to create the padding around the edge of the 
speaker. 

Reset the view 

On the View menu, click Zoom > Zoom Extents All. 

Sweep a curve along one rail 

Select the curves as illustrated. 
From the Surface menu, click Sweep 1 Rail. 

 

In the Sweep 1 Rail Options dialog box, click OK. 

 

Make a surface from planar curves 

Fill the area at the base of the padding with a planar surface created from the edge of the sweep. 

On the Surface menu, click From Planar Curves. 
Select the curve on the edge of the speaker cone as illustrated. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Sweep1.htm
http://www.rhino3d.com/5/help/Commands/PlanarSrf.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm


Chapter 15: Headphone Tutorial - Sweep, Loft, and Extrude 

75 

 
A planar surface is created at the base of the padding. 

 

Create the mounting bracket 
The next part is the bracket that holds the speaker to the headband. Since the speaker unit is 
complete, you can turn its layer off and make the Bracket layer current. 

Reset the layers 

On the status bar, click the Layer pane. 
Make Bracket the current layer and turn on Bracket Shape Curves. 
Turn all other layers off. 

Reset the view 

From the View menu, click Zoom > Zoom Extents All to zoom in on the bracket shape curves 
in all viewports. 

Extrude a curve into a solid 

Use a planar curve to create a solid shape. 

Select the closed curve. 
On the Solid menu, click Extrude Planar Curve > Straight. 

 

At the Extrusion distance… prompt, type -1 and press Enter. 

http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Fillet the edges 

Round the sharp edges with a fillet. 

On the Solid menu, click Fillet Edge > Fillet Edge. 
At the Select edges to fillet… prompt, type .2 and press Enter. 
At the Select edges to fillet… prompt, select both edges and press Enter. 

 

At the Select fillet handle to edit prompt, press Enter. 

 

Create a tubular surfaces from the shape curves 

Select the curve at the top of the bracket. 
On the Solid menu, click Pipe. 
At the Starting radius… prompt, type .3 and press Enter. 
Before typing the radius, set the command-line options to Cap=Flat and Thick=No. 

At the End radius… prompt, press Enter. 
At the Point for next radius prompt, press Enter. 

 

For the second tube 

Select the curve at the bottom of the bracket. 

http://www.rhino3d.com/5/help/Commands/FilletEdge.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
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On the Solid menu, click Pipe. 

 

At the Starting radius… prompt, type .2, and press Enter. 
At the End radius… prompt, press Enter. 
At the Point for next radius prompt, press Enter. 

 

Create the headband 
The headband consists of a series of ellipses swept along a path. 

Reset the layers 

On the status bar, click the Layer pane. 
Make Headband the current layer and turn on Headband Shape Curves. 
Turn all other layers off. 

Reset the view 

From the View menu, click Zoom > Zoom Extents All to zoom in on the bracket shape curves 
in all viewports. 

Create an ellipse perpendicular to a curve 

Turn Ortho on. 
On the Curve menu, click Ellipse > From Center. 
At the Ellipse center… prompt, click AroundCurve. 

 

At the Ellipse center prompt, snap to an endpoint of the headband curve. 
Use the End object snap. 

At the End of first axis prompt, type 0.5, and press Enter. 
At the End of first axis prompt, drag the cursor in the x-direction and click. 

http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Ellipse.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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At the End of second axis prompt, type 2, and press Enter. 
At the End of second axis prompt, drag the cursor in the y-direction and click. 

 

Array a curve along a path 

Select the ellipse. 
On the Transform menu, click Array > Along Curve. 
At the Select path curve prompt, select headband curve. 

 

In the Array Along Curve Options dialog box, under Method, set the Number of items to 3. 
Under Orientation, click Freeform, and click OK. 

 

Scale the ellipse 

Scale the center ellipse to make it larger. 

Select the center ellipse. 
On the Transform menu, click Scale > Scale1-D. 
Scale1D stretches an object in one direction. 

At the Origin point… prompt, in the Perspective viewport, snap to the center of selected 
ellipse. 
At the Scale factor or first reference point… prompt, type 2, and press Enter. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/arraycrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Scale1D.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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At the Second reference point… prompt, drag the cursor in the y-direction and click. 

Reset the view 

On the View menu, click Zoom > Zoom Extents All. 

Sweep along one rail 

Select the curves. 
From the Surface menu, click Sweep 1 Rail. 

 
At the Adjust curve seams… prompt, examine the direction and seam points of the curves to 
make sure they are not twisted, and press Enter. 
In the Sweep 1 Rail Options dialog box, click OK. 

 

Round the headband ends 
Use the same ellipse that formed the first cross-section curve for the headband to create a rounded 
end for the headband. Start by splitting the ellipse in half. 

Reset the view 

On the View menu, click Zoom > Window. 
In the Perspective viewport, zoom in on the left end of the headband you just created. 

Split the ellipse in half 

Select the ellipse. 
From the Edit menu, click Split. 

http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Split.htm
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At the Select cutting objects… prompt, type P, and press Enter. 
Turn on Quad object snap. 
At the Point to split curve prompts, snap to the two quadrants at the narrow axis of the 
ellipse. 
At the Point to split curve prompt, press Enter. 
The ellipse is split into two halves. 

 

Create a surface of revolution 

Select left half of the ellipse. 
On the Surface menu, click Revolve. 

 

At the Start of revolve axis prompt, snap to the end of the ellipse half. 
At the End of revolve axis prompt, snap to the other end of the ellipse half. 
At the Start angle... prompt, type 0, press Enter. 
At the Revolution angle... prompt, type 180, press Enter. 
A rounded surface is created at the end of the headband. 

 

Repeat these steps for the other side of the headband. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Revolve.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Join the surfaces 

Select the surfaces. 
On the Edit menu, click Join. 
Three surfaces joined into one polysurface. 

 

Create the speaker wire 
Use a separate layer to create the speaker wire. 

Reset the layers 

On the status bar, click the Layer pane. 
Make Wire Shape Curves the current layer and turn on Wire. 
Turn all other layers off. 

Reset the view 

On the View menu, click Zoom > Zoom Extents All. 

Make the helix 

On the Curve menu, click Helix. 
At the Start of axis… prompt, click AroundCurve. 
At the Select curve prompt, select the long free-form curve. 

 
At the Radius and start point… prompt, type 1 and press Enter. 
This sets the radius for the helix. 

At the Radius and start point… prompt, set Turns=30, and NumPointsPerTurn=8. 
At the Radius and start point… prompt, in the Right viewport drag the cursor to the left and 
click. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Commands/Helix.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Reset the view 

On the View menu, click Zoom > Window. 
In the Perspective viewport, zoom in on the left end of the helix you just created. 

Match and join the helix to the end curves 

From the Curve menu, click Curve Edit Tools > Match. 

 

At the Select open curve to change - pick near end prompt, select near the left end of the 
helix. 
At the Select open curve to match - pick near end… prompt, select near the lower end of 
the vertical curve. 
In the Match Curve dialog box, under Continuity, click Tangency, under Preserve other 
end, click Position, and click Join. 
Repeat steps 3 through 6 for the other end of the helix. 

Create the speaker wire 

Select the extended helical curve. 
On the Solid menu, click Pipe. 
At the Starting radius… prompt, type .2 and press Enter. 
At the End radius… prompt, press Enter. 
At the Point for next radius prompt, press Enter. 

 

Create the second wire 

Select the curve at the top left. 
On the Solid menu, click Pipe. 

http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Commands/Match.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
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At the Starting radius… prompt, type 0.1 and press Enter. 
At the End radius… prompt, press Enter. 
At the Point for next radius prompt, press Enter. 

 

Mirror the headphone parts 
Mirror the parts to create the parts for the other side of the headphones. 

Reset the layers and view 

On the status bar, click the Layer pane. 
Turn on all layers. 

Reset the view 

On the View menu, click Zoom > Zoom Extents All. 

Delete all the shape curves 

Press Esc to deselect everything. 
On the Edit menu, click Select Objects > Curves. 
Press the Delete key. 

Mirror the left half of the headphones 

In the Front viewport, window select the objects as illustrated. 
(Select the speaker, bracket, small wire, and rotated ellipse.) 

 
On the Transform menu, click Mirror. 
The Mirror command depends on which viewport is active. It uses the construction plane in the 
active viewport to define the mirror plane. The mirror plane is perpendicular to the construction 
plane. Two points define the line in this plane about which the selected objects are mirrored. 

At the Start of mirror plane prompt, type 0,0. 
This is the first point of the mirror line. 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Zoom.htm
http://www.rhino3d.com/5/help/Popup_Actions/esc_key.htm
http://www.rhino3d.com/5/help/Commands/Selection_Commands.htm#SelCrv
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
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At the End of mirror plane prompt, turn on Ortho, and drag the mirror line straight up and 
pick. 

 

Learn more 
For a video tutorial showing a more sophisticated modeling method for a headphone set using Rhino's 
Gumball feature, see: http://vimeo.com/30140235. 

http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://vimeo.com/30140235
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Chapter 16: Penguin Tutorial - Point Editing and Blending 
This tutorial demonstrates point-editing techniques including moving and scaling control points and 
adding knots to surfaces to increase control. In addition, you will use blends to create smooth 
transitions between surfaces. 

You will learn how to: 

Rebuild surfaces to add additional control points. 
Insert knots in a surface to add control points in a specific location. 
Edit surface control points to define a shape. 
Scale control points to change the object shape. 
Use object snaps projected to the construction plane. 
Orient an object on a surface. 
Create smooth blends between surfaces. 

 
Rendered with Penguin renderer by Jari Saarinen. 

The body 
If you like, open the example model, Penguin.3dm, and try to match the shapes as you are building 
the model. Experiment with your own shapes, too. 

The body and head are created from one sphere. The shape is formed by moving the control points in 
the sphere to create the head. 

Draw a sphere 

In the Top viewport, use the Sphere command to draw a sphere with a radius of 10 units. 

 

Rebuild the sphere 

Use the Rebuild command to add more control points to the sphere. 
In the Rebuild Surface dialog box, set the Point count in the U and V directions to 8 and the 
Degree in the U and V directions to 3. 

Check Delete input. 

Click OK. 

http://www.penguin3d.com/
http://www.rhino3d.com/5/help/Commands/Sphere.htm
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
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Turn control points on 

Use the PointsOn (F10) command to turn on the sphere’s control points. Look in all the 
viewports at the structure of the control points. 
The next step will change this structure so the influence of moving the control points does not 
extend over the whole sphere. 

 

Insert knots 

Use the InsertKnot command to insert two knots in the sphere in the area where you want the 
neck. 
Insert the knots in the u-direction only as illustrated. 

 
Examine the control point structure after inserting the knot. 

 
Reposition control points to create the indentation for the neck and to reform the body shape. 

Flatten the bottom 

In the Front viewport, select all the control points in the lowest rows of the sphere and use the 
SetPt command to match them to the bottom pole point in the world z-direction only. 

http://www.rhino3d.com/5/help/Commands/PointsOn.htm
http://www.rhino3d.com/5/help/Commands/InsertKnot.htm
http://www.rhino3d.com/5/help/Commands/SetPt.htm
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In the Set Points dialog box, check Set Z, clear the Set X and Set Y checkboxes, and click 
World. 

Drag the selected control points up. 

 
This will align all of the selected control points to the same z-value (up in Front viewport), 
flattening the surface. 

 

Drag points 

Select rows of control points with a window and drag them up or down in the Front viewport. 

 
Use WireFrame display mode if you find it easier to select control points in wireframe views. 

 

Scale points 

Select rows of control points with a window in the Front viewport. In the Top viewport, use the 
Scale2D command to move them closer or farther away from the central point. 
To pick the base point for the Scale2D command use the Point object snap with Project turned 
on. This will scale the points parallel to the construction plane. Watch the Front viewport to see 
the changes in the body shape as you move the control points closer to and farther from the 
center. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Scale2D.htm
http://www.rhino3d.com/5/help/Commands/Scale2D.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
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Experiment with the Project setting in the Osnap toolbar to see how it works. You will be able 
to see the tracking line projected to the construction plane in the viewports. 

Match the example model or use your own shape. 

 
Drag individual groups of control points to make the body slightly flatter in the front near the 
neck as illustrated. 

 

The eyes 
The eye is an ellipsoid shape that is oriented onto the surface. 

Create the eye 

In the Top viewport, start the Ellipsoid command. 
Place the center point anywhere. 

At the End of first axis prompt, type 1.1 to constrain the distance from the center point to the 
end of the axis to 1.1 units. 
Drag the cursor to the right and pick. 

 
At the End of second axis prompt, type 1.1 to constrain the distance. 
Using these constraints has created a circular ellipsoid when seen from the top. 

http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
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Drag the cursor up or down in the Top viewport and pick. 

 
At the End of third axis prompt, type .5, press Enter. 

 

Orient the eye on the surface 

Select the eye ellipsoid in the Top or Perspective viewport. 
Start the OrientOnSrf command. 
At the Base point (OnSurface) prompt, in the Top viewport, pick the center of the ellipsoid. 
At the Reference point for scaling and rotation prompt, pick any point to the right or left of 
the eye ellipsoid. 
The exact location is not important. 

At the Surface to orient on prompt, select the penguin body/head. 
In the Orient on Surface dialog box, click OK. 

 
At the Point on surface to orient to… prompt, move the cursor onto the head to where you 
want to place the eye and click. 

Mirror the eye 

Use the Mirror command in the Front viewport to create the second eye. 

 

http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/OrientOnSrf.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
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The beak 
The beak is another ellipsoid that you can edit to change the shape. 

Create the basic beak shape 

In the Top viewport, start the Ellipsoid command. 
Place the center point anywhere. 

At the End of first axis prompt, type 3 to constrain the distance from the center point to the 
end of the axis to three units. 
Drag the cursor to the right and pick. 

 
At the End of second axis prompt, type 2 to constrain the distance. 
Using these constraints creates a circular ellipsoid when seen from the top. 

Drag the cursor up or down in the Top viewport and pick. 

 
At the End of third axis prompt, type 1, press Enter. 

 

Shape the beak 

Turn on the control points (F10). 
In the Front viewport, select the lower row of points and drag them down. 

 

http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm
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Select the row of points in the top center and drag them down to shape the beak. 
Try using the Nudge keys (Alt + Arrow direction keys) to nudge the selected points. 

 

Move the beak 

Move the beak into position. 

 

The feet 
The feet are created using another ellipsoid. Knots are added to help create the webbed toes. 

Draw the beginning ellipsoid 

In the Front viewport, start the Ellipsoid command. 
Place the center point anywhere. 

At the End of first axis prompt, type 1 to constrain the distance from the center point to the 
end of the axis to one unit. 
Drag the cursor up and pick. 

At the End of second axis prompt, type 3 to constrain the distance. 
In the Top viewport, drag the cursor up and pick. 

At the End of third axis prompt, type 3, press Enter. 

 

Rebuild the ellipsoid 

Use the Rebuild command to add more control points to the ellipsoid. 
In the Rebuild Surface dialog box, set the Point count in the U and V directions to 8 and the 
Degree in the U and V directions to 3. 

Check Delete input. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
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Insert knots to create the webbed feet 

Use the InsertKnot command to insert four knots in the ellipsoid as illustrated. 

 
Set the Symmetrical=On. 

Insert the knots in the V-direction. 

 

Scale the points from the center 

Select control points as illustrated. 

 
Use window and crossing selections to select the control points on both the top and bottom of 
the ellipsoid. 

 
Use the Scale2D command to scale the control points out from the center of the foot. 
Use the Point object snap to set the base point of the scale to the center point of the ellipsoid. 

Drag the points to make the whole foot about twice the size of the original ellipsoid. 

http://www.rhino3d.com/5/help/Commands/InsertKnot.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Scale2D.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
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Move the foot into position 

Use the Move command to move the foot under the penguin body. 

Rotate the foot out 

Use the Rotate command to rotate the foot out slightly. 

 

Mirror the foot 

Use the Mirror command to create the second foot. 

 

Create a cutting plane 

Select the feet. 
In the Front viewport, use the CutPlane command to make a planar surface that passes 
through the feet as illustrated. 

 
The CutPlane command makes a plane that passes through the selected surfaces along the line 
you draw. 

http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Rotate.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/cutplane.htm
http://www.rhino3d.com/5/help/Commands/cutplane.htm
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Boolean the feet and the plane 

Select the plane and the feet. 
Start the Boolean2Objects command. 
Click through the preview options until the result is the flat feet as illustrated, and press Enter. 

 

The tail 
The tail is another ellipsoid. It is joined to the body with a smooth blend surface. 

Create the tail shape 

Draw an Ellipsoid that is 4 units long, 3 units wide (Top viewport), and 1.5 units tall (Front 
viewport). 

 

Position the tail 

Move and Rotate the tail in position. 

 

Union the tail and body 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/boolean2objects.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Rotate.htm
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Use the BooleanUnion command to trim and join the tail and the body shapes. 
The transition between the tail and body is rather abrupt; so replace this with a smooth blend 
surface. 

To do this, you must first create a gap between the two parts for the blend surface to fill. 

Pipe the intersection 

Use the Pipe command to create a circular surface around the edge between the body and tail. 
At the Select curve to create pipe around prompt, select the edge between the tail and the 
body. 

At the Radius for closed pipe prompt, type .4. 

 

Difference the body and tail with the pipe 

Use the BooleanDifference command to trim both the body and the tail surfaces inside the 
pipe. 
Use the DeleteInput option to delete the original surfaces. 

At the Select first set of surfaces… prompt, select the body/tail and press Enter. 
At the Select second set of surfaces… prompt, select the pipe surface and press Enter. 

 

Explode the parts 

Use the Explode command to separate the parts. 
Delete the part of the pipe remaining between the body and tail. 

 

Blend between the tail and body 

Use the BlendSrf command to create a smooth surface between the tail and the body. 

http://www.rhino3d.com/5/help/Commands/booleanunion.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Commands/booleandifference.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Explode.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
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The wings 

Create the base wing shape 

Draw an Ellipsoid that is 2 units long, 2 units wide (Top viewport), and 6.5 units tall (Front 
viewport). 

 

Rebuild the wing 

Use the Rebuild command to add more control points to the ellipsoid. 
In the Rebuild Surface dialog box, set the Point count in the U and V directions to 8 and the 
Degree in the U and V directions to 3. 

Check Delete input. 

 
Drag control points to create the shape. 

 

Bend the wing to the body 

Use the Bend command in the Front viewport to bend the top of the wing shape toward the 
body. 

http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
http://www.rhino3d.com/5/help/Commands/bend.htm
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At the Start of spine prompt, in the Front viewport, pick near the bottom of the wing. 

At the End of spine prompt, pick near the top of the wing. 

At the Point to bend through… prompt, drag the top of the wing toward the body. 

 
If further positioning is needed, use the Rotate and Move commands to place the wing. 

 

Mirror to the other side 

Use the Mirror command to create the opposite wing. 

 

Union the wing and the body 

To trim the wing hole and the wing, select both wings and the body and use the BooleanUnion 
command. 

Explode the parts 

Use the Explode command to separate the parts. 

 

http://www.rhino3d.com/5/help/Commands/Rotate.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Commands/booleanunion.htm
http://www.rhino3d.com/5/help/Commands/Explode.htm
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Pipe the intersection 

Use the Pipe command to create a circular surface around the edge between the body and each 
wing. 
At the Select curve to create pipe around prompt, select the edge of the hole in the body or 
the edge of the wing surface. 

At the Radius for closed pipe prompt, use a radius of about .6. 

 

Trim the body and wing 

Use the Trim command to trim the body and wing surfaces inside the pipe surfaces. 
Delete the pipe surfaces. 

 

Blend between the body and wing 

Use the BlendSrf command to create a smooth surface between each wing and the body. 

Join the body and wing 

Join the blends and wings to the body 

 

Finishing touches 
To finish the penguin, split the front part of the body so a different material can be applied to it. 

Draw a trim curve 

In the Right viewport, draw a Curve from the beak down to the bottom as illustrated. 

http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/Delete.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
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Split the body with the curve 

Use the Split command to split the body surface with the curve. 

Join the body parts 

Use the Join command to join the body (except the front), the tail, and the wings. 

 

Render 
Rendering creates a realistic picture of your model with colors you assign. These render colors are 
different from the layer colors you might be using, which control the display in wireframe and shaded 
modes. 

Set up the view 

Use the Rendered display mode to set the viewport rendered mode. 

Assign materials 

Select the body. 
Start the Properties command. 
In the Properties window, click the Material button. 
Set Assign material by, to Object. 
Under Basic Settings, click the Color swatch. 
In the Select Color dialog box, select a color for the body. 
Set the Gloss finish to about 40. 
Select the other parts and apply materials in the same way. 

 

http://www.rhino3d.com/5/help/Commands/Split.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Options/View/Display_Mode_Options.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm�
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm�
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Chapter 17: Boat Tutorial - Loft and Sweep 
This tutorial demonstrates classic boat hull lofting techniques using typical plan and profile curves. 
The classic hull shape is based a design from an old Boat Builder’s Handbook magazine. Many designs 
similar to this are available over the Internet. 

You will learn how to: 

Create 3-D curves from a 2-D lines drawing. 
Rebuild and simplify the curves. 
Use analytical techniques to ensure fairness. 
Loft surfaces from the curves. 

 
Rhino is used by marine designers in many segments of the industry. For more tutorials and 
information about marine design, see the Rhino Web site at www.rhino3d.com. 

Marine Terms Used in this Tutorial 

Sheer 
The fore-and-aft curvature from the bow to the stern of a ship’s deck as shown in side elevation. 

Chine 
The intersection of the bottom and the sides of a flat or v-bottomed boat. 

Transom 
The planking forming the stern of a square-ended boat. 

Fair 
The meaning of “fair” is much debated in the marine industry. No one can define it, but they know 
when they see it. Although fairing a surface is traditionally associated with hull surfaces, all visible 
surfaces on any object can benefit from this process. In Rhino, the first cue for fairness in a surface is 
the spacing of the surface display isocurves. 

There are other characteristics of fair curves and surfaces. Although a curve or surface may be fair 
without exhibiting all of the characteristics, they tend to have these characteristics. If you keep these 
in mind while modeling, you will end up with a better final product. 

The guidelines for creating a fair surface include: 

Use the fewest possible control points to get the curve shape. 
Use the fewest possible curves to get the surface shape. 

Lay out the hull curves 
The hull lines were created by tracing the original plans using a background bitmap. The first step is 
to check the lines for fairness before creating surfaces from them. 

 
The designer’s lines are illustrated. The sheer and chine have been extended at the forward and aft 
ends to accommodate the lofting process. 

http://www.rhino3d.com/


Chapter 17: Boat Tutorial - Loft and Sweep 

101 

 

Start the Model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Open the model file Victory.3dm. 
The lines are laid out on the Plan layer and the Profile layer. 

Check the curves for fairness 

Select each of the designer’s curve pairs in plan and profile and use the CurvatureGraph command 
to determine if the curves are “fair.” In this case, the file has the original curves that were traced 
from the background bitmap. They are not "fair." In other words, the curves do not smoothly 
transition from one end of the sheer to the other. If any curve is not fair, adjust points to make it fair. 
Start with the sheer (the curve at the top of the hull shape). It has the biggest impact on the 
appearance of the vessel. 

Select the curves you want to check. 
Use the CurvatureGraph command to display its curvature graph. 
The illustration shows the curvature graph applied to the two-dimensional sheer in profile. 

 
The curvature graph should be continuous and exhibit the characteristics desired for the curve. 
When the curve is concave downward, the graph will be above the curve. Conversely, concave 
upward curves will have their graphs below them. The point of inflection (where the curve is 
neither concave upward nor downward) is indicated where the graph crosses the curve. 

Rebuild the curves 

Before doing any point editing to make the curves fair, rebuild the curves to remove excess control 
points. 

Select each curve and use the Rebuild command to reduce the number of points and set the degree. 
Do not use more points than you absolutely need. 

Use the CurvatureGraph command to check the curves again for fairness. If the curvature graph is 
still not satisfactory, move the control points until you have a smooth graph. Proceed with the rest of 
the curves in the model to be certain they are fair before beginning to surface the model. 

Select the sheer curve. 
Start the Rebuild command. 
In the Rebuild Curve dialog box, change the Point count to 6 and the Degree to 5. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/Commands/CurvatureGraph.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/CurvatureGraph.htm
http://www.rhino3d.com/5/help/Commands/CurvatureGraph.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Rebuild.htm
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Create the 3-D curves 
So far, you have been working with two-dimensional curves. In order to loft the surfaces, these 
planar curves will be used to create to three-dimensional curves and the planar curves can be 
discarded. 

With the 3D Lines layer current, select the profile and plan view representations of each curve. Use 
the Crv2View command to create the three-dimensional curve that combines the x-, y-, and z-
coordinates of the two-dimensional curves. The two-dimensional curves must be planar for this 
command to work. 

Create the three-dimensional curves 

Set the 3D Lines layer current. 
Select the plan and profile representations of the sheer curve. 

 
Start the Crv2View command. 
The three-dimensional representation of that curve will be created. 

 
When you are satisfied that the proper curve was created, delete or Hide the two-dimensional 
representations. 
Repeat the Crv2View command for the chine curve. 

 

http://www.rhino3d.com/5/help/Commands/crv2view.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/crv2view.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm
http://www.rhino3d.com/5/help/Commands/crv2view.htm
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Revise the curves 
For the loft process to work on the bottom panel, it cannot come to a point. The lofted shape must be 
rectangular. This is why the curves are extended beyond the centerline. The curves can be lofted into 
a rectangular surface that can then be trimmed back. The curves in the Victory model are already 
extended for you except for the bottom centerline curve. 

Create the extended curve 

Start the Curve command. 
Use the Near object snap to place the first three control points along the centerline. 
Draw the curve so it aligns nicely with the chine and sheer curves in the plan view as illustrated. 

 

Split the centerline 

Split the centerline curve with the curve extension. 

Join the centerline and extension 

Join the curve extension to the aft part of the split centerline. 
This creates a new bottom curve to use for the surface loft. 

 

Loft the hull surfaces 
Now that you have created a set of edge curves for the side and bottom, create lofted surfaces from 
these curves. Start by lofting the bottom surface. Once you have finished it, use its upper edge as the 
curve from which to loft the side panel. 

To loft the bottom panel, select the two edges (chine and centerline) and use the Loft command. In 
this case, be sure to select the new centerline you created in the previous step. 

Loft the side and bottom and the chine and centerline 

Select the chine and 2-D centerline. 
Start the Loft command. 
In the Loft Options dialog box, under Cross-section curve options, select Rebuild with..., 
and set the control point count to 15, click OK. 

http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/Split.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Loft.htm
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Repeat the Loft for the side panel, selecting the surface edge and the sheer curve.  
Loft with the same settings in the Loft Options dialog box. 

 

Trim the bow and bottom 
When you have successfully created both the side and bottom surfaces, construct a buttock one-half 
inch off the centerline and trim both surfaces to this buttock. To do this, in the Top viewport, draw a 
line longer than the hull and one-half inch to the right of centerline. 

Draw the trim line 

In the Top viewport, draw a Line along the x-axis that is longer than the hull. 
In the Top viewport, offset the line 1/2 inch toward to hull surfaces. 

 

Trim the side and bottom to the trim line 

Use the Trim command to trim the side and bottom as illustrated. 

 

http://www.rhino3d.com/5/help/Commands/Loft.htm
http://www.rhino3d.com/5/help/Commands/Line.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
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Build the transom 
Like all surfaces in this tutorial, the transom will be built with a surface larger than the finished 
surface and then trimmed to the hull. 

To make sure there is enough surface area to trim, Extend the transom centerline by a foot or two 
both above the sheer and below the centerline. Trim the hull surfaces with the transom centerline. 

Extend the centerline 

Start the Extend command. 
At the Select boundary objects or enter extension length. Press Enter for dynamic 
extend prompt, press Enter. 
Select curve to extend… prompt, in the Front viewport, select near the top of the transom 
centerline. 
At the End of extension prompt, select a point above the current top of the transom centerline. 
At the next Select curve to extend… prompt, select near the bottom of the transom 
centerline. 
At the End of extension prompt, select a point below the current bottom of the transom 
centerline, press Enter. 

 

Trim the hull surfaces 

Select the transom centerline. 
Start the Trim command. 
In the Front viewport, at the Select object to trim… prompt, select the hull side and bottom 
surfaces aft of the transom centerline. Set UseApparentIntersections=Yes. 

 

Mirror the hull surfaces 

http://www.rhino3d.com/5/help/Commands/Extend.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
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In the Right or Top viewport, Mirror the two hull surfaces about the centerline. Use the EdgeSrf 
command to create surfaces between the two hull halves. 

Select the two hull surfaces. 
Start the Mirror command. 
In the Top viewport, at the Start of mirror plane… prompt, type 0, press Enter. 
At the End of mirror plane prompt, with Ortho on, drag the mirror plane along the x-axis, and 
click. 

 

Create the keel surface 

Start the EdgeSrf command. 
At the Select 2, 3, or 4 curves prompt, select the two inner edges of the hull bottom along the 
keel. 

 
Repeat the EdgeSrf command. 
At the Select 2, 3, or 4 curves prompt, select the two inner edges of the hull sides along the 
keel. 

 

Extrude the surface 

To create the transom surface, Extrude the transom centerline. 

In the Front viewport, select the extended transom centerline. 
Start the ExtrudeCrv command. 
At the Extrusion distance prompt, set the command-line options BothSides=Yes and 
Mode=Straight. 
In the Perspective viewport, drag the extension beyond the hull surface. 

http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Commands/EdgeSrf.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/EdgeSrf.htm
http://www.rhino3d.com/5/help/Commands/EdgeSrf.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
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Trim the transom 

Trim the transom surface with the hull and a line from the hull edges. 

Draw a line between the two hull edges. 
Start the Trim command. 

 
At the Select cutting objects prompt, select all of the hull surfaces, including the keel surface 
and the line at the top of the hull, press Enter. 
At the Select object to trim… prompt, select the transom surface outside of the hull lines, 
press Enter. 

 
The transom is now complete. Join the all surfaces. Use the ShowEdges command to check that the 
join was successful. Display the naked edges. Naked edges are surface edges that are not joined to 
other surfaces. In this case, the only naked edges should be the ones you expect around the outside 
of the hull surfaces – not those between the surfaces. 

When you have your surfaces built and joined, and have no unjoined edges, look at the surface with 
the curvature analysis tools. 

 

Add the deck 
The last step is to create the deck surface. In the profile lines, two curves describe the silhouette of 
the deck curve. You will use this curve to create the deck. 

http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/ShowEdges.htm
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Use the Project command to project the vertical line to the side of the hull. This line will act as a 
marker for the end of the curve. In the Front viewport, draw a curve from the end of the deck 
centerline curve to the end of the projected curve on one side of the hull. Use Planar mode to keep 
the curve planar. Place the first three control points using Ortho to keep them lined up at the center. 

Project the vertical deck edge to the hull 

Select the hull and the vertical line. 
In the Front viewport, use the Project command to project the curve to the hull. 
The curve will project to both sides of the hull, so you can draw your cross-section curve on 
either side. 

 

Draw the cross-section curve 

Click the Planar pane in the status bar to turn on Planar mode. 
In the Front viewport, use the Curve command to draw a control point curve from the top end 
of the deck centerline curve to the top of the curve projected to the hull. 
Use Ortho to place the first three control points in a straight line. 

 
Use the End object snap to place the last point at the top of the projected curve on the hull. 

 

http://www.rhino3d.com/5/help/Commands/Project.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Project.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm


Chapter 17: Boat Tutorial - Loft and Sweep 

109 

Create the deck surface 

Use the Sweep2 command to create the deck surface. 
At the Select rail curves prompts, select the centerline curve and the hull edge. 
At the Select cross section curves… prompt, select the cross-section curve you created from 
the deck centerline curve to the projected curve on the hull, press Enter. 

 

Mirror the deck 

Use the Mirror command to copy the deck surface to the other side. 
At the Start of mirror plane… prompt, in the Top viewport, type 0, press Enter. 

At the End of mirror plane… prompt, in the Top viewport, drag the mirror plane with Ortho 
on. 

 

Fill in the missing surface 

Use the EdgeSrf command to create the small triangular surface at the tip of the bow. 

 

Join the parts 

Select all of the surfaces and use the Join command. 

 

http://www.rhino3d.com/5/help/Commands/Sweep2.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/EdgeSrf.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
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Chapter 18: Dragonfly Tutorial - Trace Images 
This tutorial demonstrates how to get started modeling an object using photographs as reference 
material. 

You will learn how to: 

Trace an image to create profile curves. 
Create cross-section curves for lofting the profiles. 
Edit control points to change a surface shape. 

 
Starting images. 

 
Finished model. 

Note The top and side views are actually of different specimens of this dragonfly. In the side view, 
the wings are folded up. We will be using the side view image only to draw the side view curves of 
the body. 

Draw the body 
Since the dragonfly is symmetrical in the top view, and the model is not going to be a scientific 
reproduction, trace one side of the dragonfly and mirror the curve to the other side. For the side 
view, draw two curves since the profile is not symmetrical. Then we will loft cross section curves to 
make the body. The head will be made separately. 

The tail and body will all be made in one piece. The tail is actually several segments that flex. If you 
were making an animation or a scientific model, you probably would want to divide the dragonfly into 
smaller surfaces. 

Start the model 
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Begin a New model. 
In the Template File dialog box, select Small Objects - Millimeters.3dm, and click Open. 

Draw a reference line 

In the Top view use the Line command to draw a reference line 50 millimeters long starting at 
0,0,0.. 

Place the top view image 

Start PictureFrame command. 
In the Tutorial Models folder that you downloaded with the User's Guide, you will find the 
images you need for this exercise. 

Find the image file DragonFly Top.jpg, and place the image in the Top viewport. 
Use the reference line to set the length of the picture frame image. 

 

Move the image into place 

Use object snaps to Move the image from the midpoint of the left side (Mid) to the construction 
plane origin at 0,0,0.  

 

Place the side view image 

Start PictureFrame command. 
In the Tutorial Models folder that you downloaded with the User's Guide, you will find the 
images you need for this exercise. 

Find the image file DragonFly Side.jpg, and place the image in the Front viewport. 

http://www.rhino3d.com/5/help/Commands/New.htm
http://www.rhino3d.com/5/help/Commands/Line.htm
http://www.rhino3d.com/5/help/Commands/PictureFrame.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/PictureFrame.htm


Rhinoceros User's Guide 

112 

Use the reference line to set the length of the picture frame image. 

 

Using Ortho, drag the image down in the Front viewport until the reference line matches the 
center of the dragonfly body. 

 

 

Prepare the view 

Hide the side view picture frame. 

Draw the outline curve 

In the Top viewport, use the Curve command to draw an outline of the top half of the dragonfly 
body. 
Use as many control points as you think are necessary for the detail. 

Draw only up to the neck. You will be creating the head another way. 

http://www.rhino3d.com/5/help/Commands/Hide.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
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Mirror the curve 

In the Top viewport, use the Mirror command to copy the curve around the reference line. 
The photograph shows that the dragonfly is not symmetrical about its center line. However, 
since your dragonfly will be stylized, it does not matter in this case. You can choose the level of 
accuracy you need. 

 

Show the side view image 

Use the Show command to show the side-view picture frame object. 

Bend the curve 

In the Front viewport, use the Bend command to bend the curves down at the tail to match the 
bend in the body curve in that view. 

 

http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm#Show
http://www.rhino3d.com/5/help/Commands/bend.htm
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Trace side-view body 

In the Front viewport, use the Curve command trace the body outline using two curves, one 
above the reference line and one below the reference line. 
Maximize the viewport and zoom in. Pick as many points as you need to create the curves. Use 
more points when rounding a corner and fewer points for a straight section. 

 

Prepare the view 

Hide the picture frame objects and the reference line. 

Create the body surface 

Use the CSec command to create cross-section profile curves through the top, bottom, and side 
curves. 
Draw as many cross-section curves as you need to maintain the detail. You will be able to see 
whether you have enough curves when you loft the surface in the next step. If you do not have 
enough curves to maintain the shape in an area, add more and retry the surface loft. 

 

Loft the body 

Select all the cross-section curves you just created. 
Use the Loft command to create a surface through the cross-section profiles. 

http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm
http://www.rhino3d.com/5/help/Commands/csec.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Loft.htm
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Draw the head 
Draw the head with an ellipsoid and move the control points around to deform the head. The eyes are 
also ellipsoids. The neck is a surface blend. 

Draw the head 

Use the Ellipsoid command with the Diameter option to start the ellipsoid in the Front 
viewport. 
Use Elevator Mode to position the first point. 
At the Start of first axis prompt, press and hold the Ctrl key and in the Top viewport click near 
the side of the head. 

In the Front viewport, move the cursor up to the center of the head in the side view and click. 

 

At the End of first axis prompt, turn on Ortho in the Top viewport, click at the other side of 
the head. 

http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
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At the End of second axis prompt, draw pick a point in the Front viewport to establish the 
head size from front to back. 
Watch the preview in the Top viewport to check the overall size. 

 

At the End of third axis prompt, pick a point in the Front viewport at the top of the head. 

 

Note: Drawing the ellipsoid in this order and using these viewports is important to get the poles 
of the ellipsoid in the right place for the next step. 
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Rebuild the ellipsoid 

Use the Rebuild command to add more control points to the ellipsoid. 
Set the point count to 16 in the u-direction and 10 in the v-direction. 

 

Drag control points to shape the head 

Use the PointsOn command to turn on control points for the ellipsoid. 

 

In the Top viewport, select and drag points on both sides of the ellipsoid toward the back to 
deform the head. 

http://www.rhino3d.com/5/help/Commands/Rebuild.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm
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In the Right viewport, drag the middle two rows of points down. 

 

Blend the head and body 
The neck is a blend surface between the head shape and the body. First, you are going to trim the 
head shape to make an opening. 

Trim the neck 

In the Front viewport, draw lines as illustrated and use the Trim the head and body shapes with 
the lines. 

 

Blend the neck and body 

Use the BlendSrf command to make a blend surface between the head and body. 
Be sure the seams are aligned and the direction arrows point the same way. 

http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
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Draw the eyes 
The eyes are simple ellipsoids. 

Draw the base ellipsoid 

Use the Ellipsoid command to draw the eye. 
Base the size and position on the images. 

 

Position the eye 

Use the Move and Rotate commands or the Orient command to adjust the position of the eye. 

 

Mirror the other side. 

http://www.rhino3d.com/5/help/Commands/Ellipsoid.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Rotate.htm
http://www.rhino3d.com/5/help/Commands/orient.htm
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Use the Mirror command to copy the eye to the other side. 

 

Shape the tail 
The end of the tail has a rounded shape cut out of it. Use a Boolean to make this shape. 

Cap the body 

If necessary, extend the tail section by turning on the control points and dragging them to match 
the bitmap. 
Use the Cap command to make the body into a solid. 

Draw a cutting cylinder 

Use the Cylinder command to draw a solid cylinder so it cuts through the tail as illustrated. 

 

Boolean the tail 

Use the BooleanDifference command to cut the end out of the tail. 

http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Commands/cap.htm
http://www.rhino3d.com/5/help/Commands/cylinder.htm
http://www.rhino3d.com/5/help/Commands/booleandifference.htm
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Trace the wings 
The wings are solids created from closed curves. The legs are created by tracing a polyline down the 
center of a leg and using a pipe surface to make a series of tubes around the polyline. 

Draw the outline curve 

In the Top viewport, use the Curve command to trace the wings on one side of the dragonfly. 

 

Extrude the curve to make a solid 

Make the curves into thin solids with the ExtrudeCrv command. 
Set the command-line option Solid=Yes to Yes. 

 

http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
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Move the wings into position 

Position the wings on the back with the Move command. 
Consult the side view image of the dragonfly. The front wing is slightly higher than the back 
wing. 

 

Mirror the wings to the other side 

Use the Mirror command to copy the wings to the other side. 

 

Draw the legs 

Draw the base polyline 

In the Top viewport, use the Polyline command to trace down the center of the legs. 
Edit the control points to position the legs in the Top and Front viewports. 
You will have to use your imagination a little for this since the two pictures do not show the legs 
of the same insect. 

Pipe the legs 

Use the Pipe command to draw the legs around the polylines. 

http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Commands/Polyline.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
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Refer to the background picture to determine the starting and ending diameter of the pipe. 

Mirror the legs 

Use the Mirror command to copy the legs to the other side, or draw different legs for the other 
side. 

 

Finishing touches 
Add materials and textures and render. 

 

http://www.rhino3d.com/5/help/Commands/Mirror.htm
http://www.rhino3d.com/5/help/Properties/material.htm
http://www.rhino3d.com/5/help/Commands/TexturePalette.htm
http://www.rhino3d.com/5/help/Commands/Render.htm
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Chapter 19: Wrap Text Tutorial - Flow 
This tutorial demonstrates wrapping text solids and other objects on a cylinder. These objects could 
be used to trim holes in the cylinder. 

You will learn how to: 

Create text as solid objects. 
Wrap the objects to a surface. 

 

Make a surface 
For this example, create a simple cylinder. Once you have learned the basic technique, you will be 
able to use other types of surfaces. Remember that trimmed surfaces maintain their basic rectangular 
shape. This underlying shape will affect the placement of the text. 

Create a cylinder 

In the Top viewport, use the Cylinder command with the Vertical option to create a solid 
cylinder. 

 

Create the objects to wrap 
These solid objects will be wrapped on the cylinder surface. 

Create the text 

Use the TextObject command to create your text using Solids. 
Choose a font that is fairly large and blocky rather than one with many details. 

Set the Height at about 1.5 units. 

Set the Solid thickness to .1 units. 

Place the text on the construction plane near the cylinder. The location is not important. 

http://www.rhino3d.com/5/help/Commands/cylinder.htm
http://www.rhino3d.com/5/help/Commands/TextObject.htm
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Control the object placement 
The CreateUVCrv command generates the planar border curves of a surface that can be used as a 
guide to orient your text. Use the border rectangle to lay your text out before re-applying it to the 
cylinder. The rectangle then is used as a reference to guide the placement of the other objects. 

Create the UV curve 

Use the CreateUVCrv command on the cylinder side to create curves that represent the border 
of the surface on the construction plane.  
In this case a rectangle is created starting at 0,0 on the Top construction plane. 

 
Select the cylinder and use the Properties command to turn off the isocurve display on the 
cylinder. 
This will show you where the seam of the surface is located. The seam location is important 
because the rectangle edges match the top and bottom of the cylinder and the seam. Knowing 
where the seam is will help you visualize how the text will be laid out on the cylinder. 

In our example the cylinder is rotated so the seam is toward the back in the view. 

 

Position the text objects 

Move, Rotate, and Scale the text objects to arrange them inside the rectangle. 
Add any other decoration curves you want to use. 

http://www.rhino3d.com/5/help/Commands/CreateUVCrv.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Commands/Move.htm
http://www.rhino3d.com/5/help/Commands/Rotate.htm
http://www.rhino3d.com/5/help/Commands/Scale2D.htm
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Create a reference surface 

Use the PlanarSrf command to make the rectangle into a surface. 
You will use this surface later as a reference object for the FlowAlongSrf command. 

Extrude the decoration curves 

If you have created other curves, select these. 
Use the ExtrudeCrv command to thicken the decorations to match the letters. 
At the Extrusion Distance… prompt, set Cap=Yes. 
At the Extrusion distance… prompt, type .1. 

 

Wrap the objects 

Wrap the lettering on the cylinder 

Select the lettering and the decoration. 
Start the FlowAlongSrf command. 
At the Base surface… prompt, set Rigid=No. 
Click the rectangular plane near the "lower-left" corner as illustrated. 

 

At the Target surface… prompt, click the cylinder near the lower edge of the seam as 
illustrated. 

http://www.rhino3d.com/5/help/Commands/PlanarSrf.htm
http://www.rhino3d.com/5/help/Commands/FlowAlongSrf.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/FlowAlongSrf.htm
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The text solids wrap around the cylinder. 
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Chapter 20: Camera Tutorial - Blends and Trims 
At first glance, this camera model looks complex. But after a little analysis, you’ll see that it’s made of 
a three basic blocks, glued together liberally with blends. The three basic blocks are the body, the 
viewfinder, and the lens housing. 

 

The primary tool used to make this model is the BlendSrf command. It creates smooth, curvature-
continuous blends between two or more surfaces. This demonstration shows several ways of creating 
surfaces (and more importantly the gaps between surfaces) that are amenable to blending. 

 
The creation of the model can be broken into seven steps: 

Create basic body shape. 

 
Blend the front and back edges. 

 

Trim a hole in the body for the viewfinder. 

 

http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
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Create the viewfinder surface. 

 
Blend between the body and the viewfinder. 

 
Boolean bottom surface and blend bottom edge. 

 
Create lens and blend to body. 

 

Start the Model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Open the model file Camera.3dm. 
The model is organized into layers that follow the steps. You can open this model and follow 
along with the instructions by turning the layers on and off. 

Almost every stage involves the creation of a surface that will later be blended to create the 
smooth, organic model shown above. 

Create basic body shape 
The basic body shape is made of three trimmed surfaces. All three are made with extrude commands. 
The first step in creating these surfaces is to create the curves that define them. 

http://www.rhino3d.com/5/help/Commands/Open.htm


Rhinoceros User's Guide 

130 

Both the front and back surfaces have a slight curve. The back surface curves in one direction, and is 
most easily made using the ExtrudeCrv command to extrude a curve. The front surface is curved in 
two directions, so it is made by extruding one curve along another. 

Draw the profile curves 

In the Top viewport, use the Curve command to draw curves 1 and 2. 
Use the minimum number of control points necessary to create the shape. Keeping control 
points to a minimum keeps file sizes smaller, makes surfaces smoother, and makes future 
modeling tasks faster and easier. Notice that the control points are symmetrical. This ensures 
that the curve is symmetrical. In addition, the middle three control points are lined up parallel to 
the x-axis. This makes a nice smooth, flat curve that is exactly tangent to the x-axis. 

 
Draw curve 3 in the Right viewport. 
Start it at the endpoint of curve 2 and use Planar mode to keep the curve lined up. 

 

Extrude the front and back surfaces 

To create the back surface, use the ExtrudeCrv command to extrude curve 1 in the z-direction. 
Estimate the height. Make sure it is taller than curve 3. The height is not important, since the 
top will be trimmed off with the side surface. 

 
To make the front surface, use the ExtrudeCrv command to extrude curve 2 along curve 3. 

 

http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/Planar.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
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Create profile curve for side surface 

With the Curve command, create a profile curve for the side surface. 
Create this curve in the Front viewport. Be careful to make the curve start and end exactly at 
the edge of the surface. If the curve stops short, or extends beyond the bottom of the existing 
surfaces, the trim used in the next step will fail. 

 

Extrude the side surface 

With the ExtrudeCrv command, extrude the profile curve toward the back. 
Make sure it fully intersects both the front and back surfaces. An incomplete intersection will 
make the trims in the next step fail. 

 

Trim the surfaces 

Trim the three surfaces. 

Use the Trim command to trim the front and back surfaces with the extruded side surface. 

 
Use the Trim command to trim the side surface with the front and back surfaces. 

 

http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
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Blend the front and back edges 
A blend surface matches smoothly (the blend surface has curvature continuity along the edges shared 
with the other surfaces) between two or more surface edges. Blend surfaces were used for both the 
front and back edges of the camera body. Two techniques for trimming the surfaces to open up a gap 
for blending are shown in this step. 

The most straightforward and flexible method to create a gap for the first blend is to trim each 
surface with curves. This method allows the blend surface to vary in width at different points along 
the blend. 

Hide the unneeded surfaces 

Hide the back and side surfaces. 

 

Draw the profile curve 

In the Front viewport, use the Curve command to draw a profile curve. 

 

Trim the surface 

Use the Trim command to trim the surface with the profile curve. 

 

Show the surfaces 

Use ShowSelected command to unhide the side surface. 

Draw a profile curve 

In the Right viewport, use the Curve command to draw a profile curve. 
This curve is planar and lies on the construction plane in the Right viewport. 

http://www.rhino3d.com/5/help/Commands/Hide.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm#ShowSelected
http://www.rhino3d.com/5/help/Commands/curve.htm
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Trim the surface 

With the Trim command, trim the side surface with the profile curve. 

 

Blend between front and side surfaces 

Use the BlendSrf command to create a surface between the front and side surfaces. 
If you simply allow the surface to be created from the defaults, the corners will be rather square 
and the way the surface travels around the bends is not very smooth. 

To improve this, delete the original blend and make a new blend. 

 
The BlendSrf command lets you control the cross-sections of the blend. In this case set the 
bulge height to around .7 and then place cross section curves along the opening to control how 
the surface will move around the curves. 

When Rhino creates a blend, it creates a series of sections between the two surfaces to blend. 
These sections flow smoothly from one surface to the other. The number of sections you need 
depends on the complexity of the blend—use more cross-sections for more complex blends. 

 

Fillet the surfaces 

http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
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Another approach for creating a gap to blend is to create a fillet surface. A fillet surface has a 
constant radius. In the process of creating the fillet surface, both surfaces that are being filleted are 
trimmed with the new surface. You can then delete the fillet and replace it with a blend. You can also 
create a variable width blend surface with this method, but it is not as flexible as the previous 
technique. 

Use the FilletSrf command to create a rolling ball fillet surface between the back surface and 
the side surface. Use the Trim=Yes option and a radius of 0.7. 

 
> Delete the fillet surface. 

Blend the surfaces 

Use the BlendSrf command to create a blend surface in place of the fillet surface. 
Place extra cross-sections around the corners. 

 

The results may look almost identical in these pictures – and they are, almost – but when the 
model is shaded and rotated, the blend surface matches the back and side surfaces more 
smoothly because of the curvature continuity of the blend. Fillets are only tangent to the 
surfaces, blends are curvature continuous. Try it yourself to see the difference. 

Join the surfaces 

Use the Join command to join all the surfaces together into a polysurface. 

 

Trim the body for the viewfinder 
The viewfinder bulges out of the body. This bulge houses the viewfinder window and the necessary 
optical components that let you look through the camera. As with the rest of the camera, the 
viewfinder should blend in smoothly with the rest of the body. 

The blend is made with the same approach used to create the front surface blend: trim both parts 
and create a blend surface between them. Since the camera body is actually a polysurface, and the 
blend fills a more complex hole, more steps are required to create the blend. 

http://www.rhino3d.com/5/help/Commands/FilletSrf.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
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The viewfinder will wrap around the top of the body. This means that the hole in the body needs to 
wrap around the top, too. 

Draw a profile curve 

With the Curve command, draw a rough approximation of the hole the Front viewport. Draw 
the curve symmetrical about the y-axis. 
Ensure the symmetry by drawing half the curve, mirroring it about the y-axis, and joining the 
two sides. The last two control points (the ones at the end where the two halves meet) are lined 
up horizontally to ensure the curve doesn’t have a kink when mirrored. 

 

Edit the curve 

Press F10 to turn on control points and move them to get the curve to wrap around the surface. 

 
Drag the control points in the Right viewport. Turn on Ortho so that the control points only 
drag parallel to the world y-axis. 

 

Pull the trimming profile curve onto the body surfaces 

Use the Pull command to pull the curve to each surface separately, resulting in a series of 
curves. 
Delete extra curves until you have a series of curves around the surfaces that match the original 
curve as illustrated. 

http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm
http://www.rhino3d.com/5/help/Commands/Ortho.htm
http://www.rhino3d.com/5/help/Commands/Pull.htm
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Split the body parts with the curve 

Use the Split command to split each surface with the pullback curves. 
Delete the unnecessary geometry as illustrated. 

 

Create the viewfinder 
The next step in creating the viewfinder is to create the main shape of the viewfinder surface. It is a 
simple extruded surface trimmed to complement the hole in the body. 

Create the profile curve 

In the Right viewport, use the Curve command to draw a profile curve for the viewfinder 
surface. 

 

Extrude the profile curve 

Use the ExtrudeCrv command to extrude the curve in both directions from the center profile. 

 

Scale the curve 

http://www.rhino3d.com/5/help/Commands/Split.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
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To create the viewfinder trimming curve, start with the curve that was pulled back to the camera 
body. 

Use the Scale1D command to scale the curve several times to get the curve roughly the right 
shape. 

 

Scale the curve vertically in the Right viewport. 

 
Scale the curve horizontally in the Front viewport. 

 
The final shape is achieved with control point editing. 

 

Pull the curve to the surface 

With the Pull command, pull the resulting curve back to the surface. 

 

http://www.rhino3d.com/5/help/Commands/Scale1D.htm
http://www.rhino3d.com/5/help/Commands/Pull.htm
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Trim the surface 

Use the Trim command to trim the surface with the curve. 

 

Blend between the body and viewfinder 

Blending between the body and the viewfinder surface is more difficult than the blends between the 
front, back and sides because it follows such a complex path. 

Start the BlendSrf command. 
Select all the edges on the body surface (in order), then select all the edges for the viewfinder. 

 
Add enough cross sections so that the transitions around the tight turns at the back are smooth. 

 

Create bottom of camera 
At this point, the bottom of the camera is open. To close it, draw a curve that represents the bottom, 
extrude it, and use Boolean intersection to trim and join the surfaces. 

Draw the profile curve 

In the Front viewport, draw a profile curve with the Curve command. 

 

http://www.rhino3d.com/5/help/Commands/Trim.htm
http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
http://www.rhino3d.com/5/help/Commands/curve.htm
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Extrude the profile curve 

With the ExtrudeCrv command, extrude this profile curve beyond the front and back of the 
camera. 

 

Check the surface direction 

With the Dir command, check the direction of the surfaces to ensure the body points out, and 
the bottom points down. 

 
Use the Flip option to correct the direction if necessary. 

 

Boolean the parts 

Use the BooleanIntersection command to trim and join the two surfaces in one step. 

 

Create bottom edge blend 
We have used trimming and filleting to create a gap between surfaces for blending. A third technique 
for creating a gap for a blend is to create a pipe around the edge, split the surfaces with the pipe, and 
blend between them. This usually gives a slightly different result than the fillet technique. 

http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Commands/Dir.htm
http://www.rhino3d.com/5/help/Commands/booleanintersection.htm
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Extract the bottom surface 

To create the pipe, with the ExtractSrf command, extract the bottom surface from the 
polysurface. 

 

Duplicate the surface border 

Use the DupBorder command to create a single closed border curve. 
This creates a curve that can be used to create the pipe. 

 

Pipe the curve 

With the Pipe command, create a pipe surface around the duplicated border. 
Use a radius of 0.5. 

 

Split the surfaces 

With the Split command, trim the body and the bottom with the pipe. 
Delete the unnecessary pieces, including the pipe. 

 

http://www.rhino3d.com/5/help/Commands/ExtractSrf.htm
http://www.rhino3d.com/5/help/Commands/DupBorder.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Commands/Split.htm
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Blend surface on bottom surface 

With the BlendSrf command, create a blend to fill the gap. 

 

Join the parts 

With the Join command, join the parts together. 

 

Create the lens 
The last step is to create the lens and to blend the surface between them. 

Create the lens profile curve 

With the Polyline command, draw the upper half of lens profile curve. 

Round some corners 

With the Fillet command, fillet the polycurve in a few places to round of some of the sharp 
corners. 

 

Revolve the curve 

Use the Revolve command to create a revolved surface from the profile curves. 
Snap to end 1 as illustrated for the beginning of the revolve axis. Use Ortho to make the 
revolve axis parallel to the world y-axis. 

http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
http://www.rhino3d.com/5/help/Commands/Join.htm
http://www.rhino3d.com/5/help/Commands/Polyline.htm
http://www.rhino3d.com/5/help/Commands/Fillet.htm
http://www.rhino3d.com/5/help/Commands/Revolve.htm


Rhinoceros User's Guide 

142 

 

 

Create an intersection curve 

Blend between the body and the lens the same way the bottom edge was blended. 

With the Intersect command, create the intersection curve between the body and the lens 
surface. 

 

Pipe the intersection curve 

With the Pipe command, create a pipe surface around the intersection curve with a radius of 
0.15. 

 

Split the body and lens 

Split the lens and body with the pipe. 
Delete the pipe and the extra surfaces. 

http://www.rhino3d.com/5/help/Commands/Intersect.htm
http://www.rhino3d.com/5/help/Commands/Pipe.htm
http://www.rhino3d.com/5/help/Commands/Split.htm
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Blend between the body and lens 

With the BlendSrf command, fill the gap with a blend surface between body and lens. 

 

 

http://www.rhino3d.com/5/help/Commands/BlendSrf.htm
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Chapter 21: Mechanical Part Tutorial - Layouts 
This example shows how to use Rhino to model a simple mechanical part.  

You will learn to 

Create extrusion objects. 
Boolean difference shapes. 
Drill holes. 
Create a 2-D line drawing from the 3-D shapes. 
Dimension the 2-D line drawing and modify dimension text. 
Create a layout with a title block for printing. 

Open the tutorial model 

From the Rhino File menu, click Open. 
Browse to the Tutorial Models folder that you downloaded with the User's Guide. 
Click Toolblock.3dm and then click the Open button. 

 

Create solid shapes 
Start by creating two basic solid shapes from the profile curves on layers Profile-01 and Profile-02. 

Set up the layers 

In the Layers panel, confirm that the Profile-01 layer is current. 

Turn on object snaps 

Turn on the End object snap.  

Extrude the profile curve 

On the Solid menu, click Extrude Planar Curve > Straight. 
At the Select curves to Extrude prompt, select the blue profile curve, and press Enter. 

http://www.rhino3d.com/5/help/Commands/Open.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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At the Extrusion distance prompt, set the command-line Solid and the DeleteInput options 
to Yes. 
Click the end of the magenta construction line. 

 

The extruded shape is a solid because it forms a closed volume in space. 

Hide the solid 

Select the solid, on the Edit menu click Visibility > Hide. 

Set up the layers 

In the Layers panel, make layer Profile-02 current. 

Extrude the profile curve 

Select the red profile curve. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
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On the Solid menu, click Extrude Planar Curve > Straight. 
At the Select curves to Extrude prompt, set the command-line Solid and the DeleteInput 
options to Yes. 
Select the red profile curve, and press Enter. 
At the Extrusion distance prompt, in the Front viewport, drag the extrusion above the height 
of the blue curve and click.  

 

The solid appears on the current red layer Profile-01. 

 

Show the solid 

On the Edit menu click Visibility > Show. 

http://www.rhino3d.com/5/help/Commands/ExtrudeCrv.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Commands/Hide.htm#Show


Chapter 21: Mechanical Part Tutorial - Layouts 

147 

 

Set up the layers 

In the Layers panel, make layer Profile-02 current. 

Boolean the two solids 

On the Solid menu, click Difference. 
At the Select surfaces or polysurfaces to subtract from prompt, select the blue solid, and 
press Enter. 
At the Select surfaces or polysurfaces to subtract with prompt, set the command-line 
DeleteInput option to Yes. 
Select the red solid, and press Enter. 
The result will be a new solid or polysurface. A polysurface is a collection of surfaces that can be 
closed or open. A solid is a collection of surfaces that is closed. 

 

 

http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/booleandifference.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Drill the holes 
A construction circle is already in place for creating the first hole. 

Make holes in the solid 

Select the green circle as shown. 

 

On the Solid menu click Solid Edit Tools > Holes > Make Hole. 
At the Select a surface or polysurface prompt, select the blue polysurface. 
At the Cut depth point prompt, drag the hole through the upper portion of the object. 

 

Pick a point in Front view.  

 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/MakeHole.htm
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Copy the holes 

Copy the three remaining holes that are aligned with the previous hole with this command.  

In the Osnap toolbar, turn on the Point object snap.  
On the Solid menu, click Solid Edit Tools > Holes > Copy Holes.  
Note: Copy Holes is actually the MoveHole command with the command-line Copy option set 
to Yes. 

At the Select holes in one planar surface prompt, select the first hole, and press Enter.  

 

At the Point to copy from prompt, pick the point object in the center of the first circle.  
At the Point to copy to ( Copy=Yes ): prompt, pick the point that makes the center of the 
next hole.  

 

Repeat this for the two holes that are on the other side of the part.  

http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/MoveHole.htm
http://www.rhino3d.com/5/help/Commands/MoveHole.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Note: Do not the use the point in the center of the part. 

 

Create the round hole 

The center hole is different in that it does not pass entirely through the upper part of the blue solid. 
There is no reference circle to start from. 

On the Solid menu, click Solid Edit Tools > Holes > Round Hole. 
At the Select target surface prompt, select the top surface of the blue solid. 
At the Center point prompt, set the command-line options as follows: 

Depth=0.5 
Diameter=0.312 
DrillPointAngle=180 
Through=No 
Direction=CPlaneNormal 

Click the point object in the middle of the blue solid to finish creating the hole.  

http://www.rhino3d.com/5/help/Commands/RoundHole.htm
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Test the solid 

The resulting polysurface is a closed solid. A solid defines a closed volume in space. The Properties 
command will report if this part is a closed solid. The Properties command will give you information 
about the open/closed status of the object. 

Select the part. 
On the Edit menu, click Object Properties (F3). 
In the Properties panel, click the Details button. 
In the Object Description window, you will find the listing to confirm that the object is valid 
and closed. 

Geometry: 
Valid polysurface. 
Closed solid polysurface with 23 surfaces. 

Make a 2-D drawing 
The Make2D command generates 2-D lines from the 3-D solid. 

Create a 2-D line drawing 

Select the part. 
On the Dimension menu, click Make 2D. 
In the 2-D Drawing Options dialog box, under Drawing layout click 4 view (USA). 
Under Options, check the Show tangent edges and Show hidden lines boxes.  

Click OK. 

Dimension the 2-D drawing 
Using the 2-D drawing, add dimensions for the part. 

Set up the layers 

In the Layers panel, make Dimensions layer current. 
In the Layers panel, turn off all layers except Dimensions and the Make2D layers. 
In the Linetype column for the Make2D > hidden > lines layer, click Continuous. 
In the Select Linetype window, select Dashed. 

http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Make2D.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
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Set up the viewport 

Double-click the viewport title to maximize the Top viewport. 

Set up the object snaps 

In the Osnap toolbar, turn on the End object snap; turn off the Point object snap  

Dimension the part 

On the Dimension menu, click Linear Dimension.  
At the First dimension point prompt, pick the upper left end put of the part.  
At the Second dimension point prompt, pick the upper right corner of the part.  
At the Dimension location prompt, pick a location for the dimension line.  
Repeat to generate a vertical dimension on the right side of the part.  

 

Chain dimension the holes horizontally 

On the Dimension click Linear Dimension.  
At the First dimension point set the command-line Continue option to Yes.  
This will generate a chain of dimensions. 

At the First dimension point prompt, pick the lower left corner of the part.  
At the Second dimension point, prompt turn on the Cen object snap and pick the center of 
the first circle. 
At the Dimension location prompt, pick below the part.  
At the next Dimension location prompts, continue picking the centers of the circles.  
Finish by picking the lower right corner of the part, press Enter.  

http://www.rhino3d.com/5/help/Popup_MoreInformation/Object_snaps.htm
http://www.rhino3d.com/5/help/Commands/Dim.htm
http://www.rhino3d.com/5/help/Commands/Dim.htm
http://www.rhino3d.com/5/help/Popup_Actions/enter_key.htm
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Chain dimension the holes vertically 

Repeat the chain dimensions to create vertical dimensions.  

 

Add radial dimensions 

On the Dimension menu, click Radial Dimension.  
At the Select curve for radius dimension prompt, select the hole on the far right.  
At the Dimension location prompt, pick above the part.  

 

Double click the radial dimension text, and in the text edit box, add the text Typ. 5 Places. 

http://www.rhino3d.com/5/help/Commands/DimRadius.htm
http://www.rhino3d.com/5/help/Commands/EditText.htm
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Add a layout viewport 
Use a layout to arrange the 2-D lines for printer. 

On the Viewport tabs, click the Add new tab ( ) icon. 
On the menu, click New Layout.  

 

In the New Layout window, select the following: 
Landscape 
Width=11 inches 
Height=8.5 inches 
Initial Detail Count=1 

Page 1 will appear in the viewport tabs.  

 

http://www.rhino3d.com/5/help/Commands/ViewportTabs.htm
http://www.rhino3d.com/5/help/Commands/layout.htm
http://www.rhino3d.com/5/help/Commands/layout.htm
http://www.rhino3d.com/5/help/Commands/ViewportTabs.htm�
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Insert a title block 
In this section you will add a title block and resize the detail to fit. 

Set up the layer 

In the Layers panel, make the Title Block layer current. 
Confirm that you are in layout space. 

Insert the title block 

On Edit menu, click Block > Insert Block Instance. 
From the name list, select Ansi_A_TB.  
Under Insertion point, clear the Prompt checkbox, and click OK.  
Select the detail.  
Note: Click on the detail edge to select it. Make sure the detail is not active.  

On the Edit menu click Control Points > Control Points On (F10).  

 

Drag the control point in the lower left corner to resize the detail to fit in the title block.  
Press the Esc key to turn off the control points. 

Lock the detail view 

Select the detail. 
On the Edit menu, click Object Properties (F3). 
In the Properties panel on the Detail page, under Scale, set the inches on page and inches 
in model to 1.0. 
Check the Locked box 
This prevents future panning and zooming so the details stays the correct size. 

Add print widths 

In the status bar, right-click the Layer pane to open the Layer panel. 
Click Default in the PrintWidth column, and set the values to the following: 

Dimension = .35. 
Title Block = .5. 
Make2D > visible > lines = .70. 
The layout view displays a preview of the print widths as they will appear on the printed 
page. 

http://www.rhino3d.com/5/help/Commands/Layer.htm
http://www.rhino3d.com/5/help/Commands/Insert.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/PointsOn.htm
http://www.rhino3d.com/5/help/Popup_Actions/esc_key.htm
http://www.rhino3d.com/5/help/Popup_Actions/Select_objects.htm
http://www.rhino3d.com/5/help/Commands/Properties.htm
http://www.rhino3d.com/5/help/Commands/Layer.htm
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