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1 Introduction 

This tutorial describes how to model a racecar using Rhinoceros. 

There are several templates provided for your use. Each template includes a set of 
predefined layers to help you organize your model.  

Layers are a way of organizing objects so you can manipulate all the objects on a 
particular layer or keep track of them. When objects are on a layer, you can turn them all 
off at once, change the color of the wire frame display, and select them all with one 
selection. 

For more information about layers refer to the Rhino help file. 

Each of the templates has a layer with a set of wheels and axles and another layer with 
a model of a standard CO2 cartridge.  

Each template also has a layer named Max size that has rectangles that show the 
maximum size limits for the racecar. Your geometry must stay within these rectangles. 

You can turn the layers on or off at any time. Use the rectangles on these layers to check 
the size and positioning of your model. 

Template files 
Place the files that were included with the tutorial in a folder on your hard drive. 
Remember where they are located for later use. 

The files provided with this tutorial are: 

• Racecar.pdf 

• Beginner Racecar template inch.3dm 

• Beginner Racecar template mm.3dm  

• Beginner Racecar finished.3dm 

• Intermediate Racecar template inch.3dm 

• Intermediate Racecar template mm.3dm 

• Intermediate Racecar finished.3dm 

• Racecar Top.png 

• Racecar Front.png 

• Racecar Right.png 
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2 Model a CO2 Racecar for beginners 

In this part of the tutorial you will learn how to: 

• Open a rhino model 

• Save a model 

• Turn layers on and off 

• Create surfaces 

• Trim and join the surfaces to form the 
body of the racecar.  

• Extrude the cockpit curves to cutout 
the cockpit from the body. 

• Extrude the strut curves to add to the 
body 

• Use Boolean operations 

• Use a cylinder to cut out the opening 
for the CO2 cartridge 

 

 

Starting a Model with a Template 
When starting a model in Rhino you can select a template. In this part of the tutorial you 
will select the Beginner Racecar Template Inch.3dm to begin the modeling process. 
Templates contain information that helps you get started such as units, layers, viewport 
layouts, and toolbars. 

Layers 

The Racecar template for beginners includes seven predefined layers. Layers are a way 
of organizing objects so you can manipulate them separately or keep track of them in 
some way. It may help you to think of layers as transparent sheets on which you can 
place different parts of your model. 

The predefined layers have color properties that will let you distinguish various parts of 
the model more easily. In this template, all but one of the predefined layers includes 
construction geometry. 

Objects on a layer that is On are visible in the graphics area. Objects on a layer that is 
Off are not visible. Objects that are on an Unlocked layer are selectable. Objects on a 
layer that is Locked are not selectable. Geometry can only be created on the current 
layer. 

• The Max Size layer is on and locked. This layer contains rectangles that 
define the overall size of the racecar.  

• The Top Curves layer has geometry that defines the shape of the racecar. 
This layer correlates with the Top viewport. 

• The Front Curves layer contains the geometry to make surfaces for the 
struts and the cutout for the cockpit of the racecar. This layer correlates with 
the Front viewport. 
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• The Right Curves layer contains geometry with which to make the surface of 
the racecar’s topside. It also has curves for both the location of the CO2 
cartridge and the slot for the track cable. 

• The Wheel-Tire-Axle, and C02 Cartridge layers are off. You can turn them 
on during the modeling process to check the size and positioning of the 
model. 

To display a shortcut popup for layers: 

 Click the Layer pane in the status bar, at the bottom of the Rhino window. 

The popup gives you access to common layer settings: on/off, locked/unlocked, 
color, and current status. 

 

  

Current layer indicated by a 
checkmark. 

Locked layer has the lock icon 
closed. Unlocked layer has the 
lock icon open. 

  

  

On layer has light bulb icon 
lighted. 

Off layer has the light bulb icon 
grayed out. 
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To start the model 

1  On the File menu, click Open, select 
Beginner Racecar Template Inch.3dm, 
and then click Open. 

2 On the File menu, click Save As, type 
Racecar followed by your initials, and then 
click Save.  

Note:   You should save regularly and often to 
avoid the loss of data. 

3 The next time you save, click Save, instead 
of Save As.  

Making the body of the racecar 
In this step, you will use the curves in the template to make surfaces. The curves are 
organized by layer. To make it easier to select the correct curves for each surface, lock 
the layers that are not needed for each step. 

As you make the surfaces, you will notice that the surfaces are larger than necessary. 
After making the surfaces, you will learn to use Boolean commands to trim and join the 
surfaces. 

To lock a layer 

1 Click the Layer pane on the Status bar. 

2 On the Layer Shortcut Popup, click the Lock icon for the Top Curves and Front 
Curves layers. 

The lock icon is closed.  
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To make the top surface 

1 Select the five curves for the top of the 
racecar as illustrated (Right Curves layer). 

To select more than one curve hold down the 
Shift key while picking. 

 

 

2 On the Surface menu, click Loft, change 
the Style to Normal, and select Do not 
simplify for the Cross-section curve 
options, then click OK. 

If the lofted surface is not satisfactory for 
your design, you can change the shape and 
position of the curves and make the loft 
again. 

 

To make the side surfaces 

In this part of the tutorial you will be making an extruded solid.  

The extrude command has several options: Direction, BothSides, Cap, Mode, and 
DeleteInput. We will be using the BothSides option in this tutorial.  

To change the BothSides option you can click on the word BothSides on the command 
line. Each time you click it will switch the option from BothSides=No to BothSides=Yes or 
back to BothSides=No. 
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1 Unlock the layer Top Curves and lock the 
layer Right Curves. 

2 Select the curve for the side surface as 
illustrated. 

 

 

3 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

4 At the Extrusion distance… prompt, set 
BothSides=No, then type 2 and press 
ENTER.  

If the BothSides option is set to Yes, click it to 
switch it to No. 

 

 

To check the normal direction of a surface 

1 Select the lofted surface for the top of the 
racecar. 

2 On the Analyze menu, click Direction. 

3 At the Press Enter when … prompt, press 
ENTER if the arrows are pointing down. 
 
If the arrows are pointed up, click Flip, 
then press ENTER.  

Note:   The direction arrows should be pointing 
down or the next step will not give the 
correct results.  
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To subtract the top surface from the side solid 

1 Select the solid you just completed. 

2 On the Solid menu, click Difference. 

 

 

3 At the Select second set of surfaces or 
polysurfaces prompt, set 
DeleteInput=Yes, then select the top 
lofted surface, and then press ENTER. 

If the DeleteInput option is set to No, click it 
to switch it to Yes. 

This will trim and join the two pieces together.  

 

To make the cutout surface for the cockpit 

1 Unlock the layer Front Curves and lock 
the layer Top Curves. 

2 Select the U-shaped curve at the top, center 
of the model. 
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3 On the Surface menu, click Extrude 
Curve, and then click Straight. 

4 At the Extrusion distance… prompt, set 
BothSides=Yes, then type 1.25 and press 
ENTER. 
 
If the BothSides option is set to No, click it 
to switch it to Yes. 

 

To check the normal direction of a surface 

1 Select the extruded surface you just made. 

2 On the Analyze menu, click Direction. 

3 At the Press Enter when … prompt, press 
ENTER if the arrows are pointing outwards. 

If the arrows are pointed inwards, click Flip, 
then press ENTER. 

The direction arrows should be pointing 
outwards. 
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To make the cutout the cockpit 

1 Select the body of the racecar. 

2 On the Solid menu, click Difference. 

 

 

3 At the Select second set of surfaces or 
polysurfaces prompt, set 
DeleteInput=Yes, then select the 
extruded surface that will be used to cut out 
the top of the cockpit, and then press 
ENTER. 

If the DeleteInput option is set to No, click it 
to switch it to Yes. 

 

 

 

 

 



  M O D E L I N G  A  C 0 2  R A C E C A R  

Copyright © 2005 Robert McNeel & Associates. 13 

Adding details to the racecar 
In the last part of the tutorial, we will add a strut for the front axle and remove some of 
the model to make a space for a CO2 cartridge and to make a slot in the bottom.  

To make the slot for the bottom 

It might be easier to see the curves if you change 
the viewport to a wireframe display. 

1 Right click on the Perspective viewport 
title bar, then click Wireframe Display on 
the dropdown menu. 

2 UnLock the layer Right Curves and lock 
the Front Curves layer. 

3 Select the small rectangle at the bottom of 
the back of the template. 

 

 

4 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

5 At the Extrusion distance… prompt, set 
BothSides=No, then type 9 and press 
ENTER.  

6 Right click on the Perspective viewport 
title bar, then click Ghosted Display on 
the dropdown menu. 

 

To finish the slot for the bottom 

1 Select the body of the racecar. 

2 On the Solid menu, click Difference. 

3 At the prompt Select second set of 
surfaces or polysurfaces prompt, set 
DeleteInput=Yes, then select the 
extruded box you just completed, and then 
press ENTER. 
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To make the hole for the CO2 cartridge 

1 Drag the right mouse button in the 
Perspective viewport to rotate the view, 
so you can see the back of the racecar 
body. 

2 Select the circle at the back of the body. 

 

 

 

3 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

4 At the Extrusion distance… prompt, set 
BothSides=Yes, then type 3 and press 
ENTER. 

Notice that the cylinder penetrates 3 inches 
into the body and extends beyond 3 inches.  

Since we are going to remove the cylinder 
from the body with a Boolean difference 
command, having a clear intersection 
between the parts is always better than 
trying to make it flush. 

 

To make the hole for the CO2 cartridge 

1  Select the body of the racecar. 

2 On the Solid menu, click Difference. 

3 At the Select second set of surfaces or 
polysurfaces prompt, set 
DeleteInput=Yes, then select the 
cylinder, and then press ENTER. 
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To make the front axle support 

1 UnLock the layer Front Curves and lock 
the Right Curves layer. 

2  Select the curve for the strut as illustrated. 

3 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

 

 

4 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 1.125 and 
press ENTER. 

 

 

To add the support to the body 

1 Lock the layer Front Curves. 

2 On the Solid menu, click Union. 

3 At the Select surfaces or polysurfaces 
to union prompt, select the body and then 
the strut, and then press ENTER. 
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To see the finished racecar 

1 Turn on the layers Wheel-Tire-Axle and 
CO2 Cartridge. 

2 Turn off the layers Top Curves, Front 
Curves, Right Curves and Max Size. 
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3 Model a CO2 racecar for intermediate users 

In this tutorial, you will learn how to make a CO2 racecar starting from sketches. Before 
attempting this tutorial, make sure you already have experience using Rhino and that 
you understand everything discussed in Chapter 2 of this tutorial. 

You will learn how to: 

• Place Background Bitmaps 

• Use object snaps 

• Use layers 

• Make lines, curves and arcs 

• Mirror geometry 

• Extrude 2-D curves to make surfaces and 
solids 

• Use the Loft command to make a surface 

• Trim and join surfaces  

• Use the BooleanDifference command to hollow out the cockpit and make a hole for 
the CO2  cartridge 

• Use the BooleanUnion command to add struts to the body of the racecar 

Starting a Model with a Template 
When starting a model in Rhino you can select a template. In this part of the tutorial you 
will select the Intermediate Racecar Template Inch.3dm to begin the modeling 
process. Templates contain information that helps you get started such as units, layers, 
viewport layouts, and toolbars. 

This template includes eight predefined layers.  

Three of the predefined layers also include construction geometry.  

• The Max Size layer is on and locked. This layer contains rectangles that define the 
overall size of the racecar. 

• The Wheel-Tire-Axle, and C02 Cartridge layers are off. You can turn them on 
during the modeling process to check the size and positioning of the model. 

Modeling aids can help you draw the 2-D geometry with more precision. In this tutorial 
you will use the object snap (Osnap) and ortho modeling aids. You can find the controls 
for modeling aids on the status bar at the bottom of the Rhino window. 

Object snaps make it easy to snap precisely to various parts of the geometry. In this 
tutorial, we will use the End, Near, Point and Cen object snaps to attach geometry to 
the provided construction geometry. 

Note Object snaps are crucial to accurate modeling. Never try to place things visually 
on the screen; it is too difficult, and it is impossible to ensure accuracy.  
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To start the model 

1  On the File menu, click Open, select 
Intermediate Racecar Template 
Inch.3dm, and then click Open. 

2 On the File menu, click Save As 
Template, type Racecar template, then 
click Save. 

This adds the provided template file to the 
Rhino template folder. 

3 On the File menu, click New, select 
Racecar template.3dm, and then click 
Open. 

This starts a new modeling session with a file 
called unnamed.3dm.  

 

4 On the File menu, click Save, type Racecar followed by your initials, and then 
click Save. 

To turn on modeling aids 

 On the status bar, click the Osnap pane. 

These controls are toggles. Click a check box once to turn the aid on; click again to 
turn it off. When modeling aids are on, their check boxes are checked. 

Clicking the Osnap pane toggles the display of the Osnap toolbar.  

The Osnap pane text is bold only when one or more of the object snap check boxes 
are selected. 

 

You will be using the Osnap toolbar in this tutorial, so make sure it is displayed. 
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Placing the background bitmaps 
We will start by placing the background image for the top viewport. 

To place a background bitmap in the top viewport 

1 Click in the Top viewport to make it active, 
and turn on the End osnap. 

2 On the View menu, click Background 
Bitmap, then click Place, select  
Racecar Top.png and then click Open. 

3 At the First corner prompt, snap to the 
Endpoint at the lower left corner of the 
locked rectangle in the Top viewport.  

4 At the Second corner or length prompt, 
snap to the Endpoint at the upper right 
corner of the locked rectangle in the Top 
viewport.  

If you can not see the placed bitmap in the 
Top viewport background, on the View 
menu, click Background Bitmap, then click 
Show.  

 

Once you have placed the image, you can adjust it if necessary.  

To adjust background images, use View>Background Bitmap>Move to move the 
image. Use View>Background Bitmap>Scale to scale the image. Use 
View>Background Bitmap>Align to move and scale the image at the same time. 

To place a background bitmap in the front viewport 

1  Click in the Front viewport to make it 
active. On the View menu, click 
Background Bitmap, then click Place, 
select Racecar Front.png and then click 
Open. 

2 At the First corner prompt, snap to the 
Endpoint at the lower left corner of the 
locked rectangle in the Front viewport.  

3 At the Second corner or length prompt, 
snap to the Endpoint at the upper right 
corner of the locked rectangle in the Front 
viewport.  
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To place a background bitmap in the right viewport 

1  Click in the Right viewport to make it 
active. On the View menu, click 
Background Bitmap, then click Place, 
select Racecar Right.png and then click 
Open. 

2 At the First corner prompt, snap to the 
Endpoint at the lower left corner of the 
rectangle in the Right viewport. 

3 At the Second corner or length prompt, 
snap to the Endpoint at the upper right 
corner of the rectangle in the Right 
viewport.  

After placing the bitmaps and adjusting them, 
you can begin making the geometry by 
tracing over the top of the images. 

 

Making the 2D geometry 
Next, you will create the 2D geometry that to make the side, top, and bottom surfaces. 

To make the curve for the side surface 

1 Turn on the Mid osnap, and click Project 
on the Osnap toolbar. 

Project allows you to snap to geometry while 
keeping the snap point on the construction 
plane. 

2 On the Curve menu, click Free-Form, and 
then click Control Points. 

3 At the Start of curve prompt, start from 
the lower left side of the rectangle in the 
Top viewport.  

4 At the Next point prompt, continue placing 
points along the rear wheel well, and then 
continue placing points to make a curve 
that follows the outline of the bitmap. 

End the curve so that it snaps to the midpoint 
of the vertical edge at the right side of the 
rectangle. Make sure the curve stays on or 
inside the frame of the rectangle. 

The last two points (1 & 2) should be Ortho 
to each other as in the illustration on the 
right. This will insure tangency when you 
mirror the curve. 
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To mirror the curve for the side surface 

1 Select the curve you just completed. 

2 On the Transform menu, click Mirror. 

3 At the Start of mirror plane prompt, snap 
to the End of the curve you just completed. 

 

4 At the End of mirror plane prompt snap to 
the End of the construction line at the 
middle left of the rectangle. 

 

To hide the background bitmap 

When modeling you might need to turn background bitmaps on and off to make it 
easier to work with the geometry. 

1 Right-click on the Top viewport title. 

2 On the Viewport title menu, click Background bitmap, then click Hide. 

To show the background bitmap, you can repeat the process and click Show. 
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To make the curve for the back surface 

1  Turn on the Int osnap. 

2 On the Curve menu, click Line, then click 
Single line. 

3 Snap to the intersection points as illustrated 
to draw a line. 

 

To trim and join the three curves 

1 Select the line you just completed. 

2 From the Edit menu, click Trim. 

3 At the Select object to trim…, select the 
left end of each of the side curves, then 
press ENTER to end the trim command. 

 

4 Select the two side curves and the back 
line. 

5 From the Edit menu, click Join. 
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To make curves for the bottom surface, the side profile, and the cutout for the 
cockpit 

1  Change to the Front Curves layer. 

2 Turn off the Top Curves layer. 

3 On the Curve menu, click Free-Form, and 
then click Control Points. 

4 Make curves for the cockpit profile, the side 
profile, and the bottom profile of the 
racecar. 

Start and end the curves so that they extend 
beyond the construction lines. 

 

To make a copy of the side profile curve 

The side profile curve is a construction line for the right profile curves. We will make a 
copy of the curve to help in constructing the right side profiles. 

1 Select the side profile curve (middle curve). 

2 From the Transform menu, click Copy. 

3 At the Point to copy from… prompt, 
type 0 and press ENTER. 

4 At the Point to copy to prompt,  
type 0,-1.5 and press ENTER. 

 

To lock the side profile curves 

Since we are using these two curves to help construct the right side profiles, they need 
to be visible, but we don’t want to accidentally move them. Locked geometry is not 
selectable for editing, but you can still use object snaps on it. 

1 Select the two curves. 

2 From the Edit menu, click Visibility, then click Lock. 
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To make the cross-section curves for the top surface 

In this step, you will make one curve for the back of the car. Then you will copy this curve 
and adjust it to make a set of cross-section curves for the top surface of the racecar.  

This technique insures that each curve has the same degree and the same number of 
points. Using a set of curves with the same parameterization generally makes a much 
cleaner surface. 

After copying the curves, manipulate each curve by moving the control points to get the 
final shape for your racecar.   

To maintain symmetry, make one-half of the curve and then mirror it. 

1  Change to the Right Curves layer. 

2 On the Curve menu, click Free-form, and 
then click Control Points. 

3 At the Start of curve prompt, snap bottom 
end of the locked curve on the left in the 
Right viewport. 

4 At the Next point prompt, place 3 or 4 
points to the right. 

 

5 At the Next point prompt, continue placing points to match the construction arc 
on the Max Size layer. 

The arc represents the minimum clearance for the CO2 cartridge at the back of the 
racecar. 

6 End the curve so that it snaps to the midpoint of the arc. 
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To adjust the control points for the base curve 

To make sure the control points at the bottom and top of the curve are ortho to each 
other, we will use the Set Point command to position the points on the same z elevation. 

1  Select the curve you just created. 

2 From the Edit menu, click Control Points, 
then click Control Points On. 

You can also use the F10 key to turn the 
control points on. 

3 Select the control points along the bottom 
of the curve. 

4 From the Transform menu, click Set 
Points. 

 
 

5 On the Set Points dialog, uncheck X and 
Y, check Z, then click OK.  

The Align to World radio button should be 
active. 

6 At the Location for points prompt, snap the 
lower end of the locked construction line. 

7 Repeat this process for the two points at the 
top of the arc. 

 

To mirror the profile curve 

1 Select the curve you just completed. 

2 On the Transform menu, click Mirror. 

Since the orientation of the template is on the 
origin of the model, we will use the origin as 
the start of the mirror plane. 

3 At the Start of mirror plane prompt, type 
0 and press ENTER. 

4 At the End of mirror plane prompt, turn 
Ortho on and move you mouse pointer up 
or down and click. 
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To join the profile curve 

1 Select the curves you just completed. 

2 On the Edit menu, click Join. 

The two curves are joined into one. 

To place the first curve 

In this step, you will move the curve you just completed to the end of the copied side 
profile curve (locked curve). 

1 Turn on the End and Mid osnap, and 
uncheck all the others. 

2 Turn off Project. 

3 Select curve you just joined. 

4 On the Transform menu, click Move. 

5 At the Point to move from prompt, snap 
to the left End of the cross-section curve. 

6 At the Point to move to prompt, snap to 
the left End of the copied side profile curve. 

 

To copy the curves for the top of the body 

In this step you will copy the curve along the construction curve. The first set of copies 
will be for the main body and cockpit. 

1  Turn on the End, Near and Mid osnaps, 
and uncheck all the others. 

2 Copy of the curve you just completed.  

3 At the Point to copy from prompt, snap to 
the left Endpoint of the curve. 

4 At the Point to copy to prompt, snap to 
points along the copy of the side profile 
curve using the Near osnap. 

The first copy of this curve should be 
approximately 2 inches from the left end of 
the rectangle. 

The positioning of these curves will affect the 
shape of the top surface. If you are not happy 
with the shape after you make the surface, 
you can adjust the curves and remake the 
surface. 

5 Press ENTER to end the command. 
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To copy the curves for the nose 

In this step you will copy one of the copies you made in the previous step for the nose of 
the racecar. 

1 Select the last copy of the curve from the 
previous step. 

2 Copy of the curve  

3 At the Point to copy from prompt, snap to 
the Endpoint of the curve. 

  

4 At the Point to copy to prompt, snap to 
points along the original side profile curve 
using the Near osnap. 

5 Continue to copy the curve along the 
original side profile curve. 

When finished you should have six duplicate 
curves arranged like the illustrations below. 

It is generally better to have curves with 
similar structure when making surfaces. Using 
this technique, the curves will have the same 
number of control points and parameter 
spacing.  
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Making the body of the racecar 
In this step, you will use the curves you just completed to make surfaces. The surfaces 
will be larger than necessary. After making the surfaces, trim them with the adjacent 
surfaces to finish the model.  

To make the top surface 

1 Select Surfaces as the current layer. 

2 Turn the layers Top Curves, Front 
Curves, and Max Size off. 

3 Select the six curves you just completed. 

4 On the Surface menu, click Loft, change 
the Style to Loose, and select Do not 
simplify for the Cross-section curve 
options, then click OK. 

If the lofted surface is not satisfactory for 
your design, you can change the shape and 
position of the cross-section curves and make 
the loft again.  

To adjust the shape of the cross-section curves for the top of the racecar 

In this step you will adjust control points of the copied curves to develop the final shape 
for the top surface of the racecar. You will also learn how to use the nudge keys to move 
the points. 

Moving control points 

There are several methods to move the control points: 

• You can simply select and drag the control points 

With the select and drag method, you do not get much precision. 

• You can use the Move command 

The Move command allows the precision, but it can be a little tedious to use. 

• You can Nudge the control points 

Nudge gives you both precision and it is easy to use, especially when you only need 
to move the points a small amount. 

Nudge keys and direction 

Alt+Arrow keys are used for the nudge keys. The Alt+Ctrl+Arrow and the 
Alt+Shift+Arrow are variations. 

The nudge keys move the selected objects in relation to World or Construction Plane 
axes of the active viewport, Construction Plane is the default setting. Each key 
combination determines the amount of movement: 

Alt + Arrow moves .2 <units>, the Alt + Ctrl + Arrow moves .05 <units>,  
Alt + Shift + Arrow moves 2 <units> in the direction of the arrow 
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1  Select the curve to adjust. 

2 From the Edit menu, click Control Points, 
then click Control Points On. 

You can also use the F10 key to turn the 
control points on. 

3 Select the control points to adjust. 

 

4 Hold the Alt key and press one of the 
Arrow keys to move objects in the x or y 
direction in the active viewport. 

 

5 Repeat this step for the control points on 
the other side of the curve to maintain 
symmetry. 
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6 You can repeat this as needed to each of the 
cross-sections until you are satisfied with 
the shapes. 

 

7 Select all the cross-section curves . 

8 On the Surface menu, click Loft, change 
the Style to Loose, and select Do not 
simplify for the Cross-section curve 
options, then click OK. 

 

To make the side surface 

1 Turn the layer Right Curves off and Top 
Curves on. 

2 Select the curve for the sides. 

3 On the Surface menu, click Extrude 
Curve, and then click Straight. 

4 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 2 and press 
ENTER. 
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To trim and join the surfaces 

1 Turn the layer Top Curves off. 

2 Select the side surface, and the top surface. 

3 On the Edit menu, click Trim. 

4 At the Select object to trim… prompt, 
click outer edges of each surface. 

You may have to split some of the surfaces if 
Trim does not work. 

5 Select the trimmed surfaces. 

6 On the Edit menu, click Join.  
 

To make the bottom surface 

1 Turn the layer Front Curves on. 

2 Select the bottom profile. 

3 On the Surface menu, click Extrude 
Curve, and then click Straight. 

4 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 2 and press 
ENTER. 

 

To trim and join the surfaces 

1 Select the side surface, and the bottom 
surface. 

2 On the Edit menu, click Trim. 

3 At the Select object to trim… prompt, 
click outer edges of each surface. 

You may have to split some of the surfaces if 
Trim does not work. 

4 Select the trimmed surfaces. 

5 On the Edit menu, click Join.  
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Adding details to the racecar 
In the last part of the tutorial, we will add some features and remove some of the model 
to make a space for a CO2 cartridge and to make a slot in the bottom.  

To make the cutout surface for the cockpit 

1 Select the curve for the cockpit cutout. 

2 On the Surface menu, click Extrude 
Curve, and then click Straight. 

3 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 2 and press 
ENTER. 

 

To make the cutout for the cockpit 

1 Select the extruded surface that to cut out 
the top of the cockpit. 

2 On the Analyze menu, click Direction. 

3 At the Press Enter when … prompt, press 
ENTER if the arrows are pointing outwards. 
 
If the arrows are pointed inwards, click 
Flip, then press ENTER  

The direction arrows should be pointing 
outwards. 

 

4 Select the body of the racecar. 

5 On the Solid menu, click Difference. 

6 At the prompt Select second set of 
surfaces or polysurfaces prompt, set 
DeleteInput=Yes, then select the 
extruded surface that will be used to cut out 
the top of the cockpit, and then press 
ENTER. 
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To make the front axle support 

1 Change to the layer Front Curves. 

2 Turn on the Wheel-Tire layer to use as a 
reference. 

3 Turn on the Cen osnap and Project. 

4 Make an Ellipse for the front strut. 

Use the center of the axle as a reference point 
for the center of the ellipse. 

 

5 Select the ellipse. 

6 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

7 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 1.125 and 
press ENTER. 

8 Select the solid you just created and the 
body. 

9 On the Solid menu, click Union. 

Everything should be joined into one 
polysurface  

To make the slot for the bottom 

1 Turn the layer Right Curves on. 

2 Make the layer Surfaces current. 

3 From the Edit menu, click Visibility, then 
click unlock. 

This should make the rectangle and circle on 
the Right Curves layer selectable. 

4 Select the rectangle. 

5 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

6 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 9 and press 
ENTER. 
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To finish the slot for the bottom 

1 Select the body of the racecar. 

2 On the Solid menu, click Difference. 

3 At the prompt Select second set of 
surfaces or polysurfaces prompt, set 
DeleteInput=Yes, then select the 
extruded box you just completed, and then 
press ENTER. 

 

To make the hole for the CO2 cartridge 

1  Select the circle. 

2 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

3 At the Extrusion distance… prompt, set 
Bothsides=Yes, then type 2 and press 
ENTER. 

 

4 Select the body of the racecar. 

5 On the Solid menu, click Difference. 

6 At the Select second set of surfaces or 
polysurfaces prompt, set 
DeleteInput=No, then select the cylinder, 
and then press ENTER. 
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To fillet the edges 

1 From the Solid menu, click Fillet Edge. 

2 At the Select edges to fillet prompt, type 
.0625 and press ENTER. 

3 At the Select edges to fillet prompt, 
select the edges at the top and bottom of 
the racecar then press ENTER. 
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4 Preparing the model for machining 

The information contained in this part of the tutorial describes a modeling technique that 
will make it easier to mill both sides of the model with a 3-axis milling machine. 

This technique should work with any CNC system. You may have to make some 
adjustments, depending on the capabilities of your equipment and the CAM software you 
use to generate tool paths. 

To simplify things, you should start with a Balsa or Basswood block with dimensions of 
2”x4”x12”. It will be easier if you pre drill the hole for the CO2 cartridge, trim the length 
to 9.5”, and pre-cut the slot. 

Before you begin this part of the tutorial, make a copy of the racecar body and one of the 
rectangles on the Max Size layer. 

To make a copy of the racecar body and rectangle 

1 Unlock the Max Size layer. 

2 Select the finished racecar body and the 
rectangle for the max size in the x and y 
plane. 

3 From the File menu, click Export 
Selected. 

4 Save the file with another name. 

 

 

5 Open the file you just saved. 
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To make a new layer 

1 From the Edit menu, click Layers, then click Edit Layers. 

2 In the Layers dialog, click the Create New Layer icon. 

3 Name the layer Box, then make it the current layer. 

To make a stock box 
In this part of the tutorial we will make a box around the model of the body that has 
enough clearance for the cutting tool with some supports to hold the body in position 
while cutting. 

We will use the rectangle on the Max Size layer to help make the stock block. To begin, 
you will have to make another rectangle that is larger than the existing one by the size of 
the cutter you will be using. The illustrations show the stock block as a light blue color in 
a ghosted view. 

For example if you will be using a ¼” ball end mill, you will have to offset the rectangle 
at least ⅜” to allow clearance for the tool. We will assume you will be using this size 
cutter for this example.  

If you will be using a different size tool, then you can change the size of the offset.  

The second step is to make a rectangle that is the size of the stock material. 

To offset the rectangle 

1 Select the rectangle. 

2 From the Curve menu, click Offset Curve. 

3 At the Through point ( Distance=1.00  
Corner=Sharp  ThroughPoint  Tolerance ) 
prompt, type .375 and press ENTER. 

4 At the Through point prompt, click on the 
outside of the selected rectangle. 

Another rectangle is made that is larger by 
.375 units on each side. 
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To make the rectangle for the stock 

1 Turn on the Cen osnap. 

2 From the Curve menu, click Rectangle, 
then click Center, Corner. 

3 At the Center of Rectangle prompt, snap 
to the center of the rectangle you just 
made. 

4 At the Other corner or length prompt, 
type 9.5 and press ENTER. 

5 At the Width prompt, type 4 and press 
ENTER. 

Another rectangle is made that represents the 
length and width of the stock. 

 

To extrude the rectangles 

1 Select the rectangles you just completed. 

2 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

3 At the Extrusion distance… prompt, set 
Bothsides=No, then type .75 and press 
ENTER. 
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To add support bridges to the model 

The next step is to add some support bridges that connect the box with the car body. You 
will make three or four boxes or tubes that extend all the way across the stock box, two 
or three along the long edge and one along the short edge. 

This technique will allow you to cut one side of the car body while leaving the box. You 
can then flip the box over to cut the other side. After both sides are finished you can cut 
the support material away 

1 Make the geometry for the support bridges in the right & front viewports. 

Do not let the added supports intersect with the slot at the bottom of the racecar 
body.  

  

2 Select the geometry you just made. 

3 From the Solid menu, click Extrude 
Planar Curve, then click Straight. 

4 At the Extrusion distance prompt, click 
to make the extrusions intersect the inside 
edges of the box. 

 

 

5 Select the box, the car body, and the 
support bridges. 

6 From the Solid menu, click Union. 

The body, the support bridges, and the stock 
box are joined. 

The pre-drilled and cut stock block is shown 
in a light blue color 
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Milling strategy 
If you make separate tool paths for the bottom and the top of the racecar and mill the 
bottom first, it will make it easier to index the part. 

Photos of milled racecar 

  

For detailed information about milling the racecar body using RhinoCAM visit the 
RhinoCAM education web site. 
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5 Making a wheel and tire 

The information contained in this part of the tutorial describes a method for making a 
wheel and tire. 

To begin a new model 

1 From the File menu, click New. 

2 In the Open Template File dialog, click Inches.3dm. 

3 Turn on the End and Near osnaps. 

To make the construction geometry 

1 Make a centered rectangle that has a center 
point at 0, a length of 1.325, and a width of 
.75 in the Top viewport. 

This defines the maximum size for the tire 
and wheel. 

2 Make a line from the midpoint of the long 
edge to the opposite midpoint. 

Since you will only draw one-half of the 
cross-sections, the center line will help you 
maintain precision. 

 

 

To make the cross-section curves for the wheel and the tire 

1 Make a curve that defines one-half of the 
cross-section for the wheel. 

Use the Near osnap to start and end the 
curve along the center line.  
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2 Make a curve that defines one-half of the 
cross-section for the Tire. 

 

 

 

To make the wheel 
In this part of the tutorial we will make a surface revolve to finish the wheel and tire. 

1 Select the wheel cross-section. 

2 From the Surface menu, click Revolve. 

3 At the Start of revolve axis prompt, snap 
to the end of the center line. 

4 At the End of revolve axis prompt, snap to 
the other end of the center line. 

 

 

5 On the Revolve Options dialog, make the 
Simplify setting Exact, the Start angle=0, 
the End Angle=360, then click OK. 
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To make the tire 
1 Select the tire cross-section. 

2 From the Surface menu, click Revolve. 

3 At the Start of revolve axis prompt, snap 
to the end of the center line. 

4 At the End of revolve axis prompt, snap to 
the other end of the center line. 

 

 

5 On the Revolve Options dialog, click OK. 

 

6 Save the model. 

 

 

 

 


